Bug 537411 - [PATCH] Better error handling in NSS code
[PATCH] Better error handling in NSS code
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan F. Chadima
Fedora Extras Quality Assurance
:
Depends On: 356451 537397
Blocks: 543358
  Show dependency treegraph
 
Reported: 2009-11-13 09:56 EST by Pierre Ossman
Modified: 2010-03-09 08:36 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-09 08:36:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
0005-Check-the-return-value-and-print-something-useful-wh.patch (1.91 KB, patch)
2009-11-13 09:56 EST, Pierre Ossman
no flags Details | Diff
0006-Move-out-the-NSS-authentication-to-a-separate-functi.patch (2.96 KB, patch)
2009-11-13 09:56 EST, Pierre Ossman
no flags Details | Diff
0007-Make-NSS-key-handling-support-multiple-attempts-at-e.patch (5.75 KB, patch)
2009-11-13 09:56 EST, Pierre Ossman
no flags Details | Diff
0008-Improve-error-reporting-for-when-you-are-running-out.patch (1.68 KB, patch)
2009-11-13 09:57 EST, Pierre Ossman
no flags Details | Diff

  None (edit)
Description Pierre Ossman 2009-11-13 09:56:17 EST
Created attachment 369437 [details]
0005-Check-the-return-value-and-print-something-useful-wh.patch

The NSS code lacks error handling for token authentication. This patch series adds that and also makes sure that you get multiple attempts at entering your passphrase.
Comment 1 Pierre Ossman 2009-11-13 09:56:36 EST
Created attachment 369438 [details]
0006-Move-out-the-NSS-authentication-to-a-separate-functi.patch
Comment 2 Pierre Ossman 2009-11-13 09:56:53 EST
Created attachment 369439 [details]
0007-Make-NSS-key-handling-support-multiple-attempts-at-e.patch
Comment 3 Pierre Ossman 2009-11-13 09:57:11 EST
Created attachment 369440 [details]
0008-Improve-error-reporting-for-when-you-are-running-out.patch
Comment 4 Jan F. Chadima 2009-11-24 09:21:44 EST
The patches is applied in openssh-5.3p1-10.fc13, can you test it, please.
Comment 5 Pierre Ossman 2009-11-24 10:01:13 EST
Works nicely. Any chance of poking the NSS guys so that the code for a locked card will be handled?
Comment 6 Jan F. Chadima 2010-03-09 08:36:39 EST
This functionality will be discontinued due to massive upstrem changes in the
key handling. There is now pkcs11 support by Alon Bar Lev instead.

Note You need to log in before you can comment on or make changes to this bug.