Bug 537456 - Libcairo fails to load libpng with symbol not defined error
Libcairo fails to load libpng with symbol not defined error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cairo (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-13 12:16 EST by Simon Andrews
Modified: 2009-11-13 12:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-13 12:25:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Andrews 2009-11-13 12:16:31 EST
Description of problem:

There seems to be a problem with the use of libcairo in several applications where it fails to load due to an undefined symbol in libpng.  This looks like libcairo is expecting a different libpng than we currently have in F11


Version-Release number of selected component (if applicable):
cairo-1.8.8-1.fc11.x86_64
libpng-1.2.37-1.fc11.x86_64
pygtk2-libglade-2.14.1-2.fc11.x86_64
R-2.10.0-1.fc11.x86_64

How reproducible:
Always


Steps to Reproduce:
1. python -c 'import gtk.glade'

or 

1. R
2. x11()

There are probably other ways to trigger these - but these are the two we've found.
  
Actual results:

$ python -c 'import gtk.glade'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib64/python2.6/site-packages/gtk-2.0/gtk/__init__.py", line 48, in <module>
    from gtk import _gtk
ImportError: /usr/lib64/libcairo.so.2: symbol png_set_expand_gray_1_2_4_to_8, version PNG12_0 not defined in file libpng12.so.0 with link time reference

> x11()
Error in x11() : X11 module cannot be loaded
In addition: Warning message:
In x11() : unable to load shared library '/usr/lib64/R/modules//R_X11.so':
  /usr/lib64/libcairo.so.2: symbol png_set_expand_gray_1_2_4_to_8, version PNG12_0 not defined in file libpng12.so.0 with link time reference

Additional info:

Strangely cairo hasn't been updated on this machine since the end of July and these errors only started occurring in the last week or so (at least in R).  There was an R update on Nov 8th which seems to coincide with the start of these problems, so maybe there was a different version of cairo/libpng on the builders than in the repositories?  Either was R was working at the start of this week and this error happened after that.
Comment 1 Simon Andrews 2009-11-13 12:25:24 EST
Please ignore this.  Someone had installed another libpng into our LD_LIBRARAY_PATH and overwritten the system one.

Totally not fedora's fault.

Note You need to log in before you can comment on or make changes to this bug.