Bug 537567 - Keyboard layout option for 3rd level chooser stop working in F12 (on Macbook)
Summary: Keyboard layout option for 3rd level chooser stop working in F12 (on Macbook)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: card_945GM
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-14 14:31 UTC by Federico Pedemonte
Modified: 2018-04-11 08:59 UTC (History)
7 users (show)

Fixed In Version: 2.18.3-22.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-26 18:20:41 UTC


Attachments (Terms of Use)
/etc/X11/xorg.conf (797 bytes, text/plain)
2009-11-16 18:18 UTC, Federico Pedemonte
no flags Details
/tmp/dmesg (39.90 KB, text/plain)
2009-11-16 18:20 UTC, Federico Pedemonte
no flags Details
/var/log/Xorg.0.log (90.05 KB, text/plain)
2009-11-16 18:24 UTC, Federico Pedemonte
no flags Details
/var/log/Xorg.1.log (130.00 KB, text/plain)
2009-11-16 18:27 UTC, Federico Pedemonte
no flags Details
/var/log/Xorg.2.log (110.21 KB, text/plain)
2009-11-16 18:29 UTC, Federico Pedemonte
no flags Details
/var/log/Xorg.3.log (83.11 KB, text/plain)
2009-11-16 18:31 UTC, Federico Pedemonte
no flags Details
/var/log/Xorg.4.log (53.89 KB, text/plain)
2009-11-16 18:33 UTC, Federico Pedemonte
no flags Details
"kxbcomp -xkb $DISPLAY -" output (56.67 KB, text/plain)
2009-11-24 19:02 UTC, Federico Pedemonte
no flags Details
output of "xev" when pressing/release the 3rd function key (656 bytes, text/plain)
2009-11-24 19:03 UTC, Federico Pedemonte
no flags Details

Description Federico Pedemonte 2009-11-14 14:31:12 UTC
Description of problem:

On my white macbook I used to set my right "apple key" (ie the "windows" key) to access to important chars as @ # [ ] ~ that are in 3rd level.

I used to do that in the gnome "keyboard preferences" -> "layouts" -> "layout options" -> "key to choose 3rd level" checking the "right win" checkbox.  

It has always worked (at least since FC7, when I bought the mac), but stop working today after upgrading via F12-Beta DVD and then net-upgrading to the latest packages versions.

2 strange things happens:

1) the combination "right win" + "any key" doesn't produce any output (or cursor movement)

2) the thing works as expected inside gnome-terminal!!!

I've also tried making a new fresh user with newly created gnome settings but the problem is still there.

This is my smolt profile:
http://www.smolts.org/client/show/pub_fbd0b2fa-ad48-4397-a450-8e71cf95bae7

and I'm available to answer any questions or do any test could help to solve this issue!

Thanks!

Comment 1 Matěj Cepl 2009-11-16 15:48:18 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), output of the dmesg command, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Federico Pedemonte 2009-11-16 18:18:46 UTC
Created attachment 369760 [details]
/etc/X11/xorg.conf

Comment 3 Federico Pedemonte 2009-11-16 18:20:54 UTC
Created attachment 369761 [details]
/tmp/dmesg

Comment 4 Federico Pedemonte 2009-11-16 18:24:38 UTC
Created attachment 369762 [details]
/var/log/Xorg.0.log

Comment 5 Federico Pedemonte 2009-11-16 18:27:13 UTC
Created attachment 369763 [details]
/var/log/Xorg.1.log

Comment 6 Federico Pedemonte 2009-11-16 18:29:14 UTC
Created attachment 369764 [details]
/var/log/Xorg.2.log

Comment 7 Federico Pedemonte 2009-11-16 18:31:17 UTC
Created attachment 369765 [details]
/var/log/Xorg.3.log

Comment 8 Federico Pedemonte 2009-11-16 18:33:31 UTC
Created attachment 369766 [details]
/var/log/Xorg.4.log

Comment 9 Peter Hutterer 2009-11-24 06:57:44 UTC
actually, the two files i really need are:
- the output of "xkbcomp -xkb $DISPLAY -"
- the output of xev when you trigger a 3rd level key (or try to anyway).

Thanks

Comment 10 Federico Pedemonte 2009-11-24 19:02:15 UTC
Created attachment 373509 [details]
"kxbcomp -xkb $DISPLAY -" output

Comment 11 Federico Pedemonte 2009-11-24 19:03:30 UTC
Created attachment 373510 [details]
output of "xev" when pressing/release the 3rd function key

Comment 12 Federico Pedemonte 2009-11-24 19:04:47 UTC
Hi Peter, 

I've attached the output you requested!
Thanks for following this bug!

Bye, 
Federico

Comment 13 Peter Hutterer 2009-11-24 22:57:12 UTC
output looks alright to me.

(In reply to comment #0)
> 2) the thing works as expected inside gnome-terminal!!!

verified. works in gnome-terminal, xev and xterm. Doesn't work in gedit and firefox. Matthias - any hints?

command to reproduce: setxkbmap -layout it -option "lv3:rwin_switch"
rwin + q should produce '@'.

Comment 14 Matthias Clasen 2009-11-25 06:03:00 UTC
I've tracked this down to trouble with consumed modifiers when e.g. ISO_Level3_Switch and Super are mapped to the same modifier.

Comment 15 Fedora Update System 2009-11-25 06:41:45 UTC
gtk2-2.18.3-22.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gtk2-2.18.3-22.fc12

Comment 16 Federico Pedemonte 2009-11-25 18:47:55 UTC
Hi,

the gtk2 update solved the problem for the gtk2 apps, but not for Firefox.
What's next step? Should I provide more infos?

Thanks a lot!

Comment 17 Matthias Clasen 2009-11-25 19:13:51 UTC
File a separate bug against firefox, please.

Comment 18 Fedora Update System 2009-12-01 15:46:00 UTC
gtk2-2.18.4-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gtk2-2.18.4-1.fc12

Comment 19 Fedora Update System 2009-12-02 04:27:48 UTC
gtk2-2.18.3-22.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.