Bug 537615 - dhclient rewrites /etc/resolv.conf if PEERDNS=no in ifcfg-eth0
dhclient rewrites /etc/resolv.conf if PEERDNS=no in ifcfg-eth0
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-14 22:09 EST by nucleo
Modified: 2010-01-27 10:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-27 10:22:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nucleo 2009-11-14 22:09:07 EST
Description of problem:
If set PEERDNS=no in /etc/sysconfig/network-scripts/ifcfg-eth0 then dhclient writes in /etc/resolv.conf nameserver obtained from DHCP server.

Version-Release number of selected component (if applicable):
dhcp-4.1.0p1-12.fc12

How reproducible:
Every time.

Steps to Reproduce:
1. Setup eth0 and DNS with /usr/sbin/setup
2. Set PEERDNS=no, ONBOOT=yes in /etc/sysconfig/network-scripts/ifcfg-eth0
3. service network restart
  
Actual results:
dhclient rewrites /etc/resolv.conf created with /usr/sbin/setup

Expected results:
dhclient should not rewrite /etc/resolv.conf when set PEERDNS=no

Additional info:
dhcp-4_1_0p1-5_fc11 built for F12 not rewrites resolv.conf.
Comment 1 Jiri Popelka 2009-11-21 15:49:51 EST
I have been trying this on two machines but I'm not able to reproduce it.
Can you describe what exactly did you set in /usr/sbin/setup (system-config-network-tui) and what was the content of /etc/resolv.conf before and after restarting the network service ?
Comment 2 nucleo 2009-11-21 20:09:26 EST
At one installation Fedora 12 this bug can be reproduced.
But when I made new installation it can't be reproduced there.
I am trying to understand what changes in system configuration can lead to this bug.

Note You need to log in before you can comment on or make changes to this bug.