Bug 53769 - Internal compiler error in schedule_block
Internal compiler error in schedule_block
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-17 22:45 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-18 12:06:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fontfcn.i as requested (100.22 KB, text/plain)
2001-09-18 12:06 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-09-17 22:45:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)

Description of problem:
Building TrueType1 libraries as part of Apache Toolbox 1.5.38



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Download and expand Apache Toolbox on 7.1 i386 box
2.run install.sh selecting GD, php, perl, mysql...
3.type "go" to run
	

Actual Results:  [+] Getting GD lib's with zlib+PNG+JPEG+Freetype support 
ready...
[+]  zlib.tar.gz detection successful
[+]  jpegsrc.v6b.tar.gz detection successful
[+]  libpng-1.0.9.tar.gz detection successful
[+]  gd-2.0.1.tar.gz detection successful
[+]  libXpm-4.7.tar.gz detection successful
[+]  freetype-2.0.4.tar.gz detection successful
[+]  t1lib-1.1.1.tar.gz detection successful
[+]  Setting up TrueType1 libraries...
[+]   Testing t1lib-1.1.1.tar.gz for corruption... PASSED.
[+]   Untared TrueType1 libraries...
[+]   Configuring TrueType1 libraries... [DONE]
[+]   Compiling TrueType1 libraries...regions.c: In function 
`t1_SwathUnion':
regions.c:1244: Internal compiler error in schedule_block, at haifa-
sched.c:5995
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [regions.lo] Error 1
make[1]: *** [type1_target] Error 1
make: *** [XXXX] Error 1
[-]  *****zlib-compile.log FAILED!******


Check in "/dload/atb/Apachetoolbox-1.5.38/logs/zlib-compile.log" for 
errors.

-----------------
But when I look in that file, there was no error.  Here is the top and 
bottom of that file:

for i in lib type1afm examples ; do \
  (cd $i; /usr/bin/make 'CC=gcc' 'CFLAGS=-g -O2 -DT1LIB_IDENT="\"1.1.1\"" -
DGLOBAL_CONFIG_DIR="\"/usr/local/lib/php/t1libs/share/t1lib\"" -
DT1LIB_NO_X11_SUPPORT ' 'OPTIONS=' ) || exit 1; \
done
make[1]: Entering directory `/dload/atb/Apachetoolbox-1.5.38/src/t1lib/lib'
make[2]: Entering directory `/dload/atb/Apachetoolbox-
1.5.38/src/t1lib/lib/type1'
../../libtool --mode=compile \
gcc -c  -g -O2 -DT1LIB_IDENT="\"1.1.1\"" -
DGLOBAL_CONFIG_DIR="\"/usr/local/lib/php/t1libs/share/t1lib\"" -
DT1LIB_NO_X11_SUPPORT  -DT1_AA_TYPE16=short -DT1_AA_TYPE32=int  arith.c
mkdir .libs
gcc -c -g -O2 -DT1LIB_IDENT=\"1.1.1\" -
DGLOBAL_CONFIG_DIR=\"/usr/local/lib/php/t1libs/share/t1lib\" -
DT1LIB_NO_X11_SUPPORT -DT1_AA_TYPE16=short -DT1_AA_TYPE32=int arith.c  -
fPIC -DPIC -o .libs/arith.lo
gcc -c -g -O2 -DT1LIB_IDENT=\"1.1.1\" -
DGLOBAL_CONFIG_DIR=\"/usr/local/lib/php/t1libs/share/t1lib\" -
DT1LIB_NO_X11_SUPPORT -DT1_AA_TYPE16=short -DT1_AA_TYPE32=int arith.c -o 
arith.o >/dev/null 2>&1
mv -f .libs/arith.lo arith.lo
../../libtool --mode=compile \
gcc -c  -g -O2 -DT1LIB_IDENT="\"1.1.1\"" -
DGLOBAL_CONFIG_DIR="\"/usr/local/lib/php/t1libs/share/t1lib\"" -
DT1LIB_NO_X11_SUPPORT  -DT1_AA_TYPE16=short -DT1_AA_TYPE32=int  curves.c
......skipping middle
rm -f .libs/paths.lo
gcc -c -g -O2 -DT1LIB_IDENT=\"1.1.1\" -
DGLOBAL_CONFIG_DIR=\"/usr/local/lib/php/t1libs/share/t1lib\" -
DT1LIB_NO_X11_SUPPORT -DT1_AA_TYPE16=short -DT1_AA_TYPE32=int paths.c  -
fPIC -DPIC -o .libs/paths.lo
gcc -c -g -O2 -DT1LIB_IDENT=\"1.1.1\" -
DGLOBAL_CONFIG_DIR=\"/usr/local/lib/php/t1libs/share/t1lib\" -
DT1LIB_NO_X11_SUPPORT -DT1_AA_TYPE16=short -DT1_AA_TYPE32=int paths.c -o 
paths.o >/dev/null 2>&1
mv -f .libs/paths.lo paths.lo
../../libtool --mode=compile \
gcc -c  -g -O2 -DT1LIB_IDENT="\"1.1.1\"" -
DGLOBAL_CONFIG_DIR="\"/usr/local/lib/php/t1libs/share/t1lib\"" -
DT1LIB_NO_X11_SUPPORT  -DT1_AA_TYPE16=short -DT1_AA_TYPE32=int  regions.c
rm -f .libs/regions.lo
gcc -c -g -O2 -DT1LIB_IDENT=\"1.1.1\" -
DGLOBAL_CONFIG_DIR=\"/usr/local/lib/php/t1libs/share/t1lib\" -
DT1LIB_NO_X11_SUPPORT -DT1_AA_TYPE16=short -DT1_AA_TYPE32=int regions.c  -
fPIC -DPIC -o .libs/regions.lo
make[2]: Leaving directory `/dload/atb/Apachetoolbox-
1.5.38/src/t1lib/lib/type1'
make[1]: Leaving directory `/dload/atb/Apachetoolbox-1.5.38/src/t1lib/lib'



Expected Results:  Gone on to compile next module

Additional info:

I updated all HR 7.0 packages except kernel ones.
gcc-2.96-85
kernel-2.4.2-2
I also tried it with the newer kernel. had problems with that kernel 
(nothing under /lib/modules for it broke lots of things), so I reinstalled 
the whole OS to make sure.

I also tried this just downloading the ApacheToolbox script and 
downloading the script and source.
Comment 1 Jakub Jelinek 2001-09-18 04:23:08 EDT
Is it reproduceable always on the same file with the same error?
If yes, could you run
gcc -S -g -O2 -DT1LIB_IDENT=\"1.1.1\" -DGLOBAL_CONFIG_DIR=\"/usr/local/lib/php/t1libs/share/t1lib\" -DT1LIB_NO_X11_SUPPORT -DT1_AA_TYPE16=short -DT1_AA_TYPE32=int regions.c  -fPIC -DPIC -save-temps
and attach here regions.i it creates? Thanks.
Comment 2 Need Real Name 2001-09-18 12:01:06 EDT
I tried untarring the whole thing and running it several times.  I seem to get different errors:

[+]   Untared TrueType1 libraries...
[+]   Configuring TrueType1 libraries... [DONE]
[+]   Compiling TrueType1 libraries...make[2]: *** [fontfcn.lo] Error 1
make[1]: *** [type1_target] Error 1
make: *** [XXXX] Error 1
[-]  *****zlib-compile.log FAILED!******
----------------------------------------------------------------------------
[+]   Untared TrueType1 libraries...
[+]   Configuring TrueType1 libraries... [DONE]
[+]   Compiling TrueType1 libraries...hints.c: In function `t1_CloseHints':
hints.c:120: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [hints.lo] Error 1
make[1]: *** [type1_target] Error 1
make: *** [XXXX] Error 1
[-]  *****zlib-compile.log FAILED!******
----------------------------------------------------------------------------
[+]   Configuring TrueType1 libraries... [DONE]
[+]   Compiling TrueType1 libraries...hints.c: In function `ImpliedHorizontalLine':
hints.c:480: Internal error: Illegal instruction.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [hints.lo] Error 1
make[1]: *** [type1_target] Error 1
make: *** [XXXX] Error 1
[-]  *****zlib-compile.log FAILED!******
----------------------------------------------------------------------------
So it's gotta be some kinda resource issue.

Should I try to roll back to the version of gcc* that comes with RH 7.1?  
Can I just reinstall those RPM's safely or should I reinstall the OS from scratch?
Comment 3 Need Real Name 2001-09-18 12:05:33 EDT
I forgot to mention that when I tried typing in the command listed at the end of the logfile manually (without the >/dev/null 2>&1), it seemed to work.

I'll attach fontfcn.i as an example.
Comment 4 Need Real Name 2001-09-18 12:06:53 EDT
Created attachment 32038 [details]
fontfcn.i as requested
Comment 5 Jakub Jelinek 2001-09-18 13:31:43 EDT
I'd try memtest86 instead, it looks like hardware problem, be it memory,
CPU or board/chipset problem.
If it were gcc bug, it would show always on the same file the same error.
I've tried your fontfnc.i and I cannot get it to crash myself.
Comment 6 Need Real Name 2001-09-19 16:38:45 EDT
I tried memtest86 for >24 hrs, no errors.  I think I saw a program on freshmeat 
that also low-level tested some other hardware.  I'll try that tomorrow.  I'll 
also try the recompile after a fresh reboot.  Not that that ever seems to 
matter under *NIX.

Sorry for the delay, but I lost my cablemodem service for a while (Thanks, 
AT&T).

Note You need to log in before you can comment on or make changes to this bug.