This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 5378 - possible error in startkde - 1.1.2-9
possible error in startkde - 1.1.2-9
Status: CLOSED ERRATA
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-audio (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-26 15:15 EDT by Gene Czarcinski
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-30 13:26:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 1999-09-26 15:15:55 EDT
kdebase-1.1.2-9 introduces some additional code in startkde
so that IF there is NO sound card THEN kaudioserver and
kwmsound are not started.

The 19990923 version of rawhide is a bit screwed up so that
I have been unable to install it but I have installed all of
the 1.1.2 version of kde on a rhl 6.0 system.  The previous
(1.1.2-6) version of kdebase worked OK and I then updated to
the 1.1.2-9 version -- sound stopped working.

The problem is that startkde looks for (executes) the file
/etc/sysconfig/sound and this file does not exist (at least
on my rhl 6.0 system and on lorax 6.0.55 -- the file should
be /etc/sysconfig/soundcard (I think).  Unless something
else changed in the rawhide version of the system, this
needs to be fixed.

Good idea to look for the existance of the soundcard before
starting kaudioserver and kwmsound!

BTW, this is assigned to "gnome-audio" rather than kdebase
because the kde components are NOT defined for rawhide!

Gene C.
Comment 1 Preston Brown 1999-09-27 13:13:59 EDT
unfortunately, this probably won't make it for 6.1.  However, the RPMs
that will be available on the KDE site and as updates for 6.x will
have the fix.
Comment 2 Gene Czarcinski 1999-09-29 06:39:59 EDT
fixed in kdebase-1.1.2-11 which is in "updates" for 6.0.  I hope this
means that it will be in lorax.

Note You need to log in before you can comment on or make changes to this bug.