This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 538137 - scp only works one way
scp only works one way
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Jan F. Chadima
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-17 13:00 EST by Konstantin Svist
Modified: 2010-04-26 16:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-26 16:24:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Konstantin Svist 2009-11-17 13:00:56 EST
Description of problem:
scp can upload files from my new F12 box, but not download - it just stalls. Similarly, uploading to the F12 box stalls after reporting some amount of file sent (actually, destination file is 0 bytes).

How reproducible: every time


Steps to Reproduce:
[root@yggdrasil ~]# scp yum.list kostya@mireille:~
kostya@mireille's password: 
yum.list                                      100% 1528KB   1.5MB/s   00:00    
[root@yggdrasil ~]# scp kostya@mireille:~/yum.list yum.list.2
kostya@mireille's password: 
yum.list                                        0%    0     0.0KB/s - stalled -^CKilled by signal 2.


Additional info:

The F12 box is x86_64 installed from prerelease LXDE live CD and yum update'd to current.
Package openssl is ver. 1.0.0-0.10.beta3.fc12
Originally it was listed as @rawhide, but after yum reinstall it now lists @fedora instead.

I've tried disabling the firewall, and tried multiple remote machines to copy files to.
Comment 2 Jan F. Chadima 2010-02-07 23:43:58 EST
What is the description of the other site. With how many peers do you tested it?
Comment 3 Konstantin Svist 2010-04-26 16:24:15 EDT
not a bug of openssh, seems to be NIC problem

Note You need to log in before you can comment on or make changes to this bug.