Bug 53824 - tripwire is missing in action, not on CD
tripwire is missing in action, not on CD
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: tripwire (Show other bugs)
7.1
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-19 13:33 EDT by Robert M. Riches Jr.
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-22 05:07:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert M. Riches Jr. 2001-09-19 13:33:08 EDT
Description of Problem:
The tripwire RPM is simply non-existent on the Redhat Alpha Deluxe
7.1 CDs.  I searched all five Redhat CDs (didn't try Compaq stuff,
because that didn't seem to make sense).  Or, is it called by a
different name.  I did "find /mnt/cdrom -name '*tripwire*' -print"
on each CD (after mounting it, of course).

Version-Release number of selected component (if applicable):
Redhat Linux 7.1; don't know what version of tripwire is supposed
to be there, because the HTML documentation doesn't say.

How Reproducible:
100%

Steps to Reproduce:
1. mount /mnt/cdrom
2. find /mnt/cdrom -name '*tripwire*' -print
3. 

Actual Results:
nothing returned

Expected Results:
One of the CDs should have had a file called "tripwire*", according
to the HTML documentation.

Additional Information:
Comment 1 Mike A. Harris 2001-09-22 05:07:10 EDT
Looking in the src.rpm of tripwire, I see that the package has a
"ExclusiveArch: i386" line listed.  This is ordinarily present to
force package builds to only build on specific architectures due
to any number of reasons.  In other words, tripwire is not supported
on the Alpha architecture.

I will investigate the reason why it is exclusivearch'd.  In general
packages are disabled on certain architectures when they are not
critical core components of the distribution, and they have serious
problems running or building on other arch's that require a significant
amount of in-house engineering effort to fix.  Some software just
wasn't ever designed to run on non-x86 machines, and correcting the
problems in such software is usually left to those who wrote the
software upstream - at least for packages that are not core priority 1
components.

I'll look into this and update the report with the info I find out.

Comment 2 Mike A. Harris 2001-09-23 10:50:30 EDT
Yep, tripwire is not 64bit clean, which is why it is not available
for Alpha.

Note You need to log in before you can comment on or make changes to this bug.