Bug 538262 (abrtf12) - SELinux is preventing /usr/bin/python "create" access on rpmfusion-free-debuginfo.
Summary: SELinux is preventing /usr/bin/python "create" access on rpmfusion-free-debug...
Keywords:
Status: CLOSED ERRATA
Alias: abrtf12
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:045c02e73e6...
: 538309 538488 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-18 02:58 UTC by reelkaas
Modified: 2010-06-24 18:08 UTC (History)
8 users (show)

Fixed In Version: 3.6.32-49.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-01 16:40:16 UTC


Attachments (Terms of Use)

Description reelkaas 2009-11-18 02:58:26 UTC
Summary:

SELinux is preventing /usr/bin/python "create" access on
rpmfusion-free-debuginfo.

Detailed Description:

[yumdownloader has a permissive type (abrt_t). This access was not denied.]

SELinux denied access requested by yumdownloader. It is not expected that this
access is required by yumdownloader and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:abrt_t:s0
Target Context                system_u:object_r:rpm_var_cache_t:s0
Target Objects                rpmfusion-free-debuginfo [ dir ]
Source                        yumdownloader
Source Path                   /usr/bin/python
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.6.2-2.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-41.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.5-127.fc12.i686 #1 SMP Sat
                              Nov 7 21:41:45 EST 2009 i686 i686
Alert Count                   1
First Seen                    Wed 18 Nov 2009 03:51:33 AM CET
Last Seen                     Wed 18 Nov 2009 03:51:33 AM CET
Local ID                      ffc705ec-8be5-4982-b077-a77e87553a34
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1258512693.59:24408): avc:  denied  { create } for  pid=10574 comm="yumdownloader" name="rpmfusion-free-debuginfo" scontext=system_u:system_r:abrt_t:s0 tcontext=system_u:object_r:rpm_var_cache_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1258512693.59:24408): arch=40000003 syscall=39 success=yes exit=0 a0=a2b5938 a1=1ed a2=2d1a868 a3=9cee050 items=0 ppid=10332 pid=10574 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="yumdownloader" exe="/usr/bin/python" subj=system_u:system_r:abrt_t:s0 key=(null)



Hash String generated from  selinux-policy-3.6.32-41.fc12,catchall,yumdownloader,abrt_t,rpm_var_cache_t,dir,create
audit2allow suggests:

#============= abrt_t ==============
allow abrt_t rpm_var_cache_t:dir create;

Comment 1 Daniel Walsh 2009-11-18 12:40:36 UTC
Fixed in selinux-policy-3.6.32-46.fc12.noarch

Please grab out of updates-testing

Comment 2 Daniel Walsh 2009-11-18 12:47:10 UTC
*** Bug 538309 has been marked as a duplicate of this bug. ***

Comment 3 Daniel Walsh 2009-11-18 18:14:21 UTC
*** Bug 538488 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2009-11-23 23:35:24 UTC
selinux-policy-3.6.32-49.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-49.fc12

Comment 5 Fedora Update System 2009-11-25 15:18:18 UTC
selinux-policy-3.6.32-49.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12131

Comment 6 Fedora Update System 2009-12-02 04:30:00 UTC
selinux-policy-3.6.32-49.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.