Bug 53899 - eth0 does not secure dhcp lease from server following upgrade to RH7.1
eth0 does not secure dhcp lease from server following upgrade to RH7.1
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: dhcpcd (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-20 19:17 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-20 19:18:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-09-20 19:17:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)

Description of problem:
Here is what I have: 
Abit KT7 motherboard using Duron 600 processor 
3Com 3C900B-TPO PCI ethernet card 
RH7.1 
kernel is 2.4.7 ( same problem with 2.4.2 & 2.4.3 ) 
dhcpcd is the default version shipped with RH7.1 
( same problem using the version shipped with RH7.0 ) 
NIC modules is 3c59x 
3Com website indicates this is the correct module, and 
lsmod verifies that it is loading correctly 
no interrupt conflicts 
as verified in /cat/interrupts 
plug N pray is disabled in the BIOS 

eth0 interface does not come up; yields the message that it times out 
waiting for a valid response from the dhcp server. 
eth0 interface will come up using a static IP; however, I can not ping 
anything but the eth0 address, not even the firewall/router. 

System works perfectly with the default installation under RH7.0 and the 
2.2.16 kernel. 

Is there something that changed from RH7.0 to RH7.1 or from 2.2 to 2.4 
that would cause this behavior?

May be related (doubtful) to bug 53037.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RH7.1
2.Boot machine
3.
	

Actual Results:  dhcpcd times out waiting for a valid response from the 
dhcp server

Expected Results:  client should secure a dhcp lease from the server

Additional info:

dhcpcd worked perfectly under RH7.0 and the 2.2.16 kernel
same system - does not work under RH7.1 and the 2.4.x kernel

Note You need to log in before you can comment on or make changes to this bug.