Bug 53907 - libgnomecanvas libpango libart_lgpl are rawhide missing components for bug report
libgnomecanvas libpango libart_lgpl are rawhide missing components for bug re...
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-libs (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-21 06:10 EDT by Gilles J. Seguin
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-21 10:10:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilles J. Seguin 2001-09-21 06:10:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-2.9 i486)

Description of problem:
bug reports against missing component in bugzilla.
bug reports against libgnomecanvas libpango libart_lgpl libgnomeprint15 can
not be done.

The following bug need to be moved to the libgnomecanvas component.
The rawhide-release-20010827 has a new component, that is
libgnomecanvas-1.103.0-1.i386.rpm which will not install with option -Uvh.
 error: failed dependencies:
        libpango-0.17.so   is needed by libgnomecanvas-1.103.0-1
# rpm -ql pango
/usr/lib/libpango-0.18.so
# rpm -q pango
pango-0.18-3
which is the package from current rawhide release

Install has been tried with this version of the rpm utilities.
# rpm -q rpm
rpm-4.0.3-1.04


Version-Release number of selected component (if applicable):
libgnomecanvas-1.103.0-1.i386.rpm
pango-0.18-3.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. rpm -Uvh libgnomecanvas-1.103.0-1.i386.rpm
2.
3.
	

Actual Results:  error: failed dependencies:
        libpango-0.17.so   is needed by libgnomecanvas-1.103.0-1


Expected Results:  libgnomecanvas-1.103.0-1.i386.rpm should accept a
library which is more recent, that is libpango-0.18.so


Additional info:

recompilation with modified spec file has not be tried.
I personnely do not know about the compatibility with
libpango-0.18.so
Comment 1 Havoc Pennington 2001-09-21 19:29:16 EDT
Yeah, rawhide gnome 2 packages will be broken for the forseeable future. 
I'm now working against 7.2 instead of in rawhide, nothing compiles in rawhide
due to autotools, etc. breakage.

Anyway, not worth leaving the bug open, it will get fixed eventually because I'l
l eventually have to  rebuild all of gnome in rawhide.

Note You need to log in before you can comment on or make changes to this bug.