Bug 53908 - message:
message:
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-21 07:19 EDT by Orca Lonsdale
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orca Lonsdale 2001-09-21 07:19:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
Serial port problem: Starting Linux gives as one of the messages: "LSR 
Safety check engaged!" when Linux during the startup is starting the 
console mouse services.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. just start Linux (in either text or KDE mode) suffices
2.
3.
	

Actual Results:  The message "LSR Safety check engaged!" appears during 
startup of Linux RedHat 7.1 and the mouse won't work.
Funny that the mouse worked during the setup of RedHat 7.1 in the graphics 
mode.

Expected Results:  guess what? :))
the mouse should have worked.

Additional info:

Starting X (by just typing X in a console) gives an X screen, but no 
serial mouse activity.
Starting KDE (by typing startx) gives a hanging KDE screen. Changing 
to 'term 1' then shows again the "LSR Safety check engaged!" message.
Running gpm -t ms -m /dev/ttyS0 (as I have a microsoft compatible mouse 
on 'COM1') also gives the message, and the prompt only returns when Ctrl-C 
is pressen.
This appears to be a 'serial driver' problem with some UART 16550A chips 
(which appear to have). I have no PS2 port, so I've got no workaround 
here. Please help.
Looking in Google under "LSR Safety check engaged" shows that a lot of 
pple have the same problem....
I haven't fount the remedy though on the web.
Comment 1 Bernhard Rosenkraenzer 2002-01-17 10:03:36 EST
grepping the source tree shows this message is generated by the kernel when it
finds an extremely buggy UART chipset. (linux/drivers/char/serial.c)

There's nothing gpm can do about it; if it can be fixed, it can be fixed in the
serial driver. Assigning.
Comment 2 Bugzilla owner 2004-09-30 11:39:11 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.