Bug 53933 - upgrade problem with shared library libcrypto.so.1
Summary: upgrade problem with shared library libcrypto.so.1
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openldap   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-22 08:53 UTC by Nicolas CROISET
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-22 08:53:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nicolas CROISET 2001-09-22 08:53:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; fr-FR; rv:0.9.2) Gecko/20010726
Netscape6/6.1

Description of problem:
If I want to upgrade to openldap-2.0.11-8 under redhat 7.0 with the command
rpm -Uvh openldap-2.0.11-8
I obtain this error message :
error: failed dependencies:
        libcrypto.so.1   is needed by openldap-2.0.11-8
        libssl.so.1   is needed by openldap-2.0.11-8
If I search to update this library :
rpm -Uvh openssl-0.9.6-9.i386.rpm
I obtain this error :
error: failed dependencies:
        libcrypto.so.0 is needed by cyrus-sasl-1.5.24-6
        libcrypto.so.0 is needed by python-1.5.2-27
        libcrypto.so.0 is needed by stunnel-3.8-4
        libcrypto.so.0 is needed by fetchmail-5.5.0-3
        libcrypto.so.0   is needed by openssh-2.5.2p2-1.7
        libcrypto.so.0   is needed by openssh-server-2.5.2p2-1.7
        libcrypto.so.0   is needed by openssh-clients-2.5.2p2-1.7
        libcrypto.so.0 is needed by php-4.0.5-1
        libssl.so.0 is needed by python-1.5.2-27
        libssl.so.0 is needed by stunnel-3.8-4
        libssl.so.0 is needed by fetchmail-5.5.0-3
        libssl.so.0 is needed by php-4.0.5-1


Version-Release number of selected component (if applicable):


How reproducible:
Always

Additional info:

I have at this time openssl-0.9.5a-14 and openldap-1.2.11-15

Comment 1 Nicolas CROISET 2001-09-22 09:13:20 UTC
I find my problem. I make a rpm -i openssl095a-0.9.5a-9.i386.rpm, and then
everything is fine.


Note You need to log in before you can comment on or make changes to this bug.