Bug 53938 - LTCONFIG_VERSION undefined, bind-9.2.0-0.rc3.1
LTCONFIG_VERSION undefined, bind-9.2.0-0.rc3.1
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: bind (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
: 54257 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-22 20:01 EDT by kenneth_porter
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-22 20:01:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kenneth_porter 2001-09-22 20:01:51 EDT
Building bind-9.2.0-0.rc3.1.src.rpm on Red Hat 7.1. libtool fails, 
complaining that ltconfig's version does not match version of ltmain.sh. 
Checking bind's BUILD/bind-9.2.0rc3/libtool against /usr/bin/libtool, it 
appears that LTCONFIG_VERSION is not defined in the bind-supplied copy of 
libtool.

Workaround is to predefine LTCONFIG_VERSION:

export LTCONFIG_VERSION=1.3.5
rpm --rebuild bind-9.2.0-0.rc3.1.src.rpm
Comment 1 Bernhard Rosenkraenzer 2001-09-27 09:08:34 EDT
The alternative fix is to update your libtool. No problems here on a rawhide 
system with libtool 1.4.2 (and rawhide RPMs don't need to compile on older 
releases).
I'll add the check and possible export in the next build (after 0.rc4.1, that 
is - 0.rc4.1 has been in the internal tree for a while).

Comment 2 Bernhard Rosenkraenzer 2001-10-02 18:06:16 EDT
*** Bug 54257 has been marked as a duplicate of this bug. ***
Comment 3 Bernhard Rosenkraenzer 2001-10-02 18:28:00 EDT
Added a workaround in 9.2.0-0.rc5.1
Comment 4 Joerg Dorchain 2001-10-03 04:06:47 EDT
updating libtool gives strange depenencies:
php (as shipped which 7.1) requires libltdl.so, but in a different major version
than the one supllied by libtool-libs-1.4-8. This makes you update php because
you want to compile bind.
IMHO adding the aclocal and autoconf to the spec file has fewer side effects.

Note You need to log in before you can comment on or make changes to this bug.