Bug 53942 - RFE: add kdb and sgi's lkcd to kernel
RFE: add kdb and sgi's lkcd to kernel
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-23 11:41 EDT by Ed McKenzie
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 14:03:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed McKenzie 2001-09-23 11:41:45 EDT
RedHat kernels should ship with a proper debugger and crash dumper.  This
is a pretty controversial issue, but my vote is 'yes' -- afaict kdb/lkcd
don't affect those who don't use it, and it's useful to those who do need it.

(This is not a feature request for 7.2.)
Comment 1 Arjan van de Ven 2001-09-23 11:49:18 EDT
If you look in recent kernels (2.4.7-6 etc) you can see that there already is a
kernel with the kdb integrated in the form of the kernel-debug package.

As for the crashdump; crashdumps as done the SGI way are inherently unsafe (the
kernel state is foobar and THEN writing huge amounts of data to disk.... if
either  the scsi layer or scsi device driver was the reason for the crash you
might end up dumping your data over what WAS your oracle customer database).
We're considering it or better alternatives though.
Comment 2 Ed McKenzie 2001-09-23 15:00:52 EDT
I'm guessing that since there's only an i686 version of the -debug kernel in
rawhide, there won't be an i386/586 version next release -- right?
Comment 3 Arjan van de Ven 2001-09-23 15:08:48 EDT
No; not precompiled; on debug kernel takes up enough space already....
However you probably can build a i586 one yourself by doing

rpm --rebuild --with debug --target=ii586 kernel-2.4.X-Y.src.rpm

Or just add the patch you your own kernel build using kernel-source.. the patch
is there

Note You need to log in before you can comment on or make changes to this bug.