Bug 53943 - sawfish appearance applet crash
sawfish appearance applet crash
Status: CLOSED DUPLICATE of bug 54491
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-23 13:29 EDT by Sam Varshavchik
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-30 13:20:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
strace of child sawfish-ui process. (5.81 KB, text/plain)
2001-09-23 13:30 EDT, Sam Varshavchik
no flags Details
after sawfish-ui aborts, the parent process goes into an infinite loop. (558 bytes, text/plain)
2001-09-23 13:30 EDT, Sam Varshavchik
no flags Details

  None (edit)
Description Sam Varshavchik 2001-09-23 13:29:24 EDT
After upgrading from 7.1 to 7.2, the sawfish appearance configuration
applet locks up before initializing.

stracing /usr/bin/sawfish-capplet-appearance shows the sawfish-ui process
crashing with an internal error, causing the parent applet process to get
stuck in an infinite loop.
Comment 1 Sam Varshavchik 2001-09-23 13:30:07 EDT
Created attachment 32438 [details]
strace of child sawfish-ui process.
Comment 2 Sam Varshavchik 2001-09-23 13:30:49 EDT
Created attachment 32439 [details]
after sawfish-ui aborts, the parent process goes into an infinite loop.
Comment 3 Sam Varshavchik 2001-09-30 13:20:26 EDT
Backing out patch2 from sawfish src rpm eliminates this crash.

The bad font name is the original problem, and the problem itself manifests
itself with sawfish not being able to recover gracefully from sawfish-ui crashing.
Comment 4 Havoc Pennington 2002-03-01 10:28:35 EST
More bad font repercussions

(Set your locale to en_US, should fix this.)

*** This bug has been marked as a duplicate of 54491 ***

Note You need to log in before you can comment on or make changes to this bug.