Bug 539540 - [abrt] crash detected in compiz-0.8.2-19.fc12 #1 in enableFragmentProgramAndDrawGeometry at paint.c:883
[abrt] crash detected in compiz-0.8.2-19.fc12 #1 in enableFragmentProgramAndD...
Status: CLOSED DUPLICATE of bug 540718
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
abrt_hash:3cf3a75a5c304a799df4c32b630...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-20 09:14 EST by Volans
Modified: 2009-12-09 19:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-09 19:27:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (27.56 KB, text/plain)
2009-11-20 09:14 EST, Volans
no flags Details
dmesg output file (32.33 KB, text/plain)
2009-11-24 18:00 EST, Volans
no flags Details
Xorg.0.log file (32.29 KB, text/plain)
2009-11-24 18:01 EST, Volans
no flags Details
Xorg.9.log file (25.13 KB, text/plain)
2009-11-24 18:02 EST, Volans
no flags Details

  None (edit)
Description Volans 2009-11-20 09:14:15 EST
abrt detected a crash.

Attached file: backtrace
cmdline: compiz --ignore-desktop-hints glib gconf gnomecompat
component: compiz
executable: /usr/bin/compiz
kernel: 2.6.31.5-127.fc12.i686.PAE
package: compiz-0.8.2-19.fc12
rating: 4
reason: Process was terminated by signal 11
Comment 1 Volans 2009-11-20 09:14:18 EST
Created attachment 372497 [details]
File: backtrace
Comment 2 Hamidou Dia 2009-11-20 21:42:09 EST
Hi Volans,

We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please could you attach to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below your:

1) X server config file (/etc/X11/xorg.conf, if available)
2) Output of the dmesg command, and X server log file (/var/log/Xorg.*.log)

As well, could you eventually give us a hint about how this crash occurred?

As a last request, if this crash is reproducible, could I ask you if are able
to trigger it with KMS disabled? 

We will review this issue again once you've had a chance to attach this
information.

Thanks in advance.


Regards

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Volans 2009-11-23 18:39:04 EST
Hello,

Well I don't have the bug report anymore. I sent this report using the automatic bug reporting tool. I thought you would get it, so I didn't save it...

Anyway, I don't have the /etc/X11/xorg.conf . Since Fedora 11, I don't see it in my /etc/X11 folder.

I'll attach the output of the dmesg command, and the two /var/log/Xorg.*.log files like you requested.

The crash was unexpected and unnoticed. I only got a warning that a crash had happened, and nothing more. I didn't even notice it. I wish I could reproduce it, but I can't. :)
Comment 4 Hamidou Dia 2009-11-23 19:18:36 EST
Hi Volans.

So we will look forward for your /var/log/Xorg.*.log files and your dmesg output attached to this ticket.

Many thanks.

Regards.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Hamidou Dia 2009-11-24 07:57:12 EST
Volans,

Have you been able to find a moment to upload the needed files for this ticket?

Regards.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Volans 2009-11-24 18:00:59 EST
Created attachment 373576 [details]
dmesg output file
Comment 7 Volans 2009-11-24 18:01:38 EST
Created attachment 373577 [details]
Xorg.0.log file
Comment 8 Volans 2009-11-24 18:02:41 EST
Created attachment 373579 [details]
Xorg.9.log file
Comment 9 Volans 2009-11-24 18:03:52 EST
Here you go. :) About the Xorg.conf file, it doesn't exist in my system (Fedora 12).
Comment 10 fkfire 2009-11-24 18:21:14 EST
I also experienced a similar crash (same line of code, at least) on an intel 855GM card. When it happens (fairly randomly), compiz dies and must be manually started again.
Comment 11 Matěj Cepl 2009-11-24 18:47:13 EST
Thread 1 (Thread 1595):
#0  0x00000000 in ?? ()
No symbol table info available.
#1  0x0806bd53 in enableFragmentProgramAndDrawGeometry (
    mask=<value optimized out>, filter=<value optimized out>, 
    attrib=<value optimized out>, texture=<value optimized out>, 
    w=<value optimized out>) at paint.c:883
        param = 0
        function = <value optimized out>
        fa = {opacity = 65535, brightness = 48970, saturation = 32395, 
          nTexture = 0, function = {1, 0 <repeats 15 times>}, nFunction = 1, 
          nParam = 1}
        s = <value optimized out>
        blending = <value optimized out>
#2  drawWindowTexture (mask=<value optimized out>, 
    filter=<value optimized out>, attrib=<value optimized out>, 
    texture=<value optimized out>, w=<value optimized out>) at paint.c:1170
        filter = 1
#3  0x002a13dc in videoDrawWindowTexture (w=<value optimized out>, 
    texture=<value optimized out>, attrib=<value optimized out>, 
    mask=<value optimized out>) at video.c:487
        s = 0x8632d80
        vs = 0x89e6a50
#4  0x0806b7b8 in drawWindow (w=<value optimized out>, 
    transform=<value optimized out>, fragment=<value optimized out>, 
    region=0x8f980b8, mask=1) at paint.c:1209
No locals.
#5  0x00be1104 in svgDrawWindow (w=<value optimized out>, 
    transform=<value optimized out>, attrib=<value optimized out>, 
    region=<value optimized out>, mask=<value optimized out>) at svg.c:266
        status = <value optimized out>
        ss = 0x89e8170
#6  0x0029ffa0 in videoDrawWindow (w=<value optimized out>, 
    transform=<value optimized out>, attrib=<value optimized out>, 
    region=<value optimized out>, mask=<value optimized out>) at video.c:504
        status = <value optimized out>
        vs = 0x89e6a50
#7  0x0037327e in decorDrawWindow (w=<value optimized out>, 
    transform=<value optimized out>, attrib=<value optimized out>, 
    region=<value optimized out>, mask=<value optimized out>)
    at decoration.c:188
        status = <value optimized out>
        ds = 0x89ff4b0
#8  0x00526e43 in obsDrawWindow (w=<value optimized out>, 
    transform=<value optimized out>, attrib=<value optimized out>, 
    region=<value optimized out>, mask=<value optimized out>) at obs.c:277
        fragment = {opacity = 48690, brightness = 2054, saturation = 3553, 
          nTexture = 151085272, function = {0, 1056964608, 1152, 145616784, 
            0, 3, 0, 8, -1078605472, 5332120, 150409360, 0, -1078605832, 
            5315903, 150409360, 0}, nFunction = -1078605624, 
          nParam = 141033000}
        factor = <value optimized out>
        s = 0x8632d80
        hasCustomFactor = <value optimized out>
        status = <value optimized out>
        i = <value optimized out>
        os = 0x8f6f7b0
        ow = <value optimized out>
Comment 12 Matěj Cepl 2009-12-09 19:27:03 EST

*** This bug has been marked as a duplicate of bug 540718 ***

Note You need to log in before you can comment on or make changes to this bug.