Bug 53958 - client side libmilter support missing
client side libmilter support missing
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-24 09:36 EDT by bastiaan
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-02 09:19:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bastiaan 2001-09-24 09:36:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.6 i686; en-US; rv:0.9.1)
Gecko/20010608

Description of problem:
The sendmail RPM appears to be built with libmilter support. But it's not
possible to build an actual filter, because the include files and
libmilter.a are missing from the distribution.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -q -l sendmail | grep libmilter.a
2.
3.
	

Actual Results:  nothing

Expected Results:  the location of an included libmilter library

Additional info:

Something to put in a 'sendmail-devel' RPM?
Comment 1 Matt Biermann 2001-10-01 14:50:47 EDT
Is it possible to build the libmilter client side and add it to the sendmail
package, or as an enhancement?  Attempting to use milter and I'm hitting a wall.
Comment 2 bastiaan 2001-10-02 09:19:23 EDT
Hi Bierman,

To use milter, the sendmail executable should be compiled with milter support
(i.e. the milter server side).If I haven't mixed up the different releases,
RH7.1 sendmail is compiled with milter support. (in any case for RawHide I'm
sure it has been).
Now to use milter, you also need actual mailt filters (the client). To compile
these you need libmilter.a, libsmutil.a and the headers files. The RawHide RPM
seems to include libmilter.a, but not the header files. It would be nice if
these were added to the package. In the mean time you can use the headers from a
separate sendmail source tar ball.
  
 
Comment 3 Florian La Roche 2001-12-07 16:23:24 EST
Fixed in 8.11.6-5 or newer from rawhide.

Thanks,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.