Bug 539581 - SELinux is preventing /usr/bin/abrt-pyhook-helper "write" access on /var/cache/abrt.
Summary: SELinux is preventing /usr/bin/abrt-pyhook-helper "write" access on /var/cach...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:2097ef3f561...
: 539584 540184 540185 540186 540187 540188 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-20 16:42 UTC by Eric Jansen
Modified: 2009-12-02 04:39 UTC (History)
10 users (show)

Fixed In Version: 3.6.32-49.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-01 16:40:45 UTC


Attachments (Terms of Use)

Description Eric Jansen 2009-11-20 16:42:01 UTC
Summary:

SELinux is preventing /usr/bin/abrt-pyhook-helper "write" access on
/var/cache/abrt.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by abrt-pyhook-hel. It is not expected that this
access is required by abrt-pyhook-hel and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:sambagui_t:s0-s0:c0.c1023
Target Context                system_u:object_r:abrt_var_cache_t:s0
Target Objects                /var/cache/abrt [ dir ]
Source                        abrt-pyhook-hel
Source Path                   /usr/bin/abrt-pyhook-helper
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-addon-python-0.0.11-1.fc12
Target RPM Packages           abrt-0.0.11-1.fc12
Policy RPM                    selinux-policy-3.6.32-46.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31.5-127.fc12.i686.PAE #1 SMP Sat Nov 7
                              21:25:57 EST 2009 i686 i686
Alert Count                   3
First Seen                    Sat 21 Nov 2009 12:42:00 AM SGT
Last Seen                     Sat 21 Nov 2009 12:42:00 AM SGT
Local ID                      b3a6e1e9-f26c-439f-93e4-8b94926798c2
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1258735320.580:53): avc:  denied  { write } for  pid=3245 comm="abrt-pyhook-hel" name="abrt" dev=sda2 ino=84455 scontext=system_u:system_r:sambagui_t:s0-s0:c0.c1023 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1258735320.580:53): avc:  denied  { add_name } for  pid=3245 comm="abrt-pyhook-hel" name="pyhook-1258735320-3231.lock" scontext=system_u:system_r:sambagui_t:s0-s0:c0.c1023 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1258735320.580:53): avc:  denied  { create } for  pid=3245 comm="abrt-pyhook-hel" name="pyhook-1258735320-3231.lock" scontext=system_u:system_r:sambagui_t:s0-s0:c0.c1023 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=lnk_file

node=(removed) type=SYSCALL msg=audit(1258735320.580:53): arch=40000003 syscall=83 success=yes exit=0 a0=bf96b40e a1=951d0cc a2=909990 a3=bf96b3fe items=0 ppid=3231 pid=3245 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrt-pyhook-hel" exe="/usr/bin/abrt-pyhook-helper" subj=system_u:system_r:sambagui_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-46.fc12,catchall,abrt-pyhook-hel,sambagui_t,abrt_var_cache_t,dir,write
audit2allow suggests:

#============= sambagui_t ==============
allow sambagui_t abrt_var_cache_t:dir { write add_name };
allow sambagui_t abrt_var_cache_t:lnk_file create;

Comment 1 Eric Jansen 2009-11-20 16:46:13 UTC
This issue happened when creating new Samba user name. I have upgraded from testing repo selinux-policy-3.6.32-46.fc12.noarch, but it seems no luck with samba.

Comment 2 Daniel Walsh 2009-11-20 16:57:42 UTC
This is an abrt problem

Comment 3 Daniel Walsh 2009-11-20 16:59:24 UTC
*** Bug 539584 has been marked as a duplicate of this bug. ***

Comment 4 Daniel Walsh 2009-11-20 17:00:10 UTC
Oops, nope this is mine.

Fixed in selinux-policy-3.6.32-48.fc12.noarch

Comment 5 Miroslav Grepl 2009-11-23 08:50:31 UTC
*** Bug 540184 has been marked as a duplicate of this bug. ***

Comment 6 Miroslav Grepl 2009-11-23 08:51:11 UTC
*** Bug 540185 has been marked as a duplicate of this bug. ***

Comment 7 Miroslav Grepl 2009-11-23 08:51:50 UTC
*** Bug 540186 has been marked as a duplicate of this bug. ***

Comment 8 Miroslav Grepl 2009-11-23 08:52:40 UTC
*** Bug 540187 has been marked as a duplicate of this bug. ***

Comment 9 Miroslav Grepl 2009-11-23 08:53:11 UTC
*** Bug 540188 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2009-11-23 23:38:05 UTC
selinux-policy-3.6.32-49.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-49.fc12

Comment 11 Fedora Update System 2009-11-25 15:21:05 UTC
selinux-policy-3.6.32-49.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12131

Comment 12 Fedora Update System 2009-12-02 04:32:35 UTC
selinux-policy-3.6.32-49.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.