Bug 53960 - Apache fails to start
Apache fails to start
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-24 10:00 EDT by Andy Wallace
Modified: 2008-01-17 12:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 06:31:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Wallace 2001-09-24 10:00:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010809

Description of problem:
Description of problem:
running /etc/rc.d/init.d/httpd start results in FAILED.

further checking into it, the httpd script tries to start apache like this:

/usr/sbin/httpd -DHAVE_ACCESS -DHAVE_PROXY
-DHAVE_AUTH_ANON -DHAVE_ACTIONS -DHAVE_ALIAS -DHAVE_ASIS -DHAVE_AUTH
-DHAVE_AUTOINDEX -DHAVE_AUTH_DB -DHAVE_AUTH_DBM -DHAVE_CERN_META -DHAVE_CGI
-DHAVE_DIGEST -DHAVE_DIR -DHAVE_ENV -DHAVE_EXAMPLE -DHAVE_EXPIRES
-DHAVE_HEADERS -DHAVE_IMAP -DHAVE_INCLUDE -DHAVE_INFO -DHAVE_LOG_AGENT
-DHAVE_LOG_CONFIG -DHAVE_LOG_REFERER -DHAVE_MIME -DHAVE_MIME_MAGIC
-DHAVE_MMAP_STATIC -DHAVE_NEGOTIATION -DHAVE_REWRITE -DHAVE_SETENVIF
-DHAVE_SPELING -DHAVE_STATUS -DHAVE_UNIQUE_ID -DHAVE_USERDIR
-DHAVE_USERTRACK -DHAVE_VHOST_ALIAS -DHAVE_DAV -DHAVE_PERL -DHAVE_SSL
-DHAVE_PHP4            

Which results in:
[FAILED]

apache-1.3.20-15
mod_perl-1.24_01-3

Everything install of Roswell Beta2 with all updates applied.

This seems to be related to closed bug 52535 although the results differ
somewhat. 

If I keep the <IfDefine HAVE_PERL> lines in httpd.conf (i.e. as per default
configuration) around the LoadModule and AddModule directives, Apache fails
to start and httpd -t gives the following error:

Syntax error on line 1447 of /etc/httpd/conf/httpd.conf:
Invalid command 'PerlSetupEnv', perhaps mis-spelled or defined by a module
not included in the server configuration.

(This command is at the start of a PerlModule definition, part of the setup
of Bronc, an RRDtool front-end -- but that's irrelevant, and just suggests
that mod_perl is not getting loaded).

If I comment out the <IfDefine>'s httpd -t gives Segmentation Fault.

If I put <IfDefine HAVE_PERL> around the PerlModule section, Apache still
fails to start, but httpd -t gives Syntax OK. 

Version-Release number of selected component (if applicable):
apache-1.3.20-15

How reproducible:
Always

Steps to Reproduce:
1. Edit /etc/httpd/conf/httpd.conf as above
2. etc/rc.d/init.d/httpd start

	

Actual Results:  Service FAILED startup, but after further looking into it,
apache says "Segmentation fault" or "Syntax error on line xxx" where the 
mod_perl module configuration starts.

Expected Results:  Apache should startup OK

Additional info:

Perl configuration added to the end of httpd.conf:

PerlSetupEnv Off
PerlSetEnv PERL5LIB /usr/lib/perl5:/usr/lib/apache/perl
PerlRequire modules/perl/startup.pl
PerlRequire modules/perl/mason_handler.pl
<Location /perl-status>
  SetHandler  perl-script
  PerlHandler Apache::Status
</Location>

<VirtualHost 192.168.1.12:80>
<Location /grapher>
  SetHandler  perl-script
  PerlHandler BRONC::Grapher
</Location>
<Location />
  SetHandler perl-script
  PerlHandler HTML::Mason
</Location>
ServerAdmin andyw2@btconnect.com
DocumentRoot /home/bronc/htdocs
ServerName roswell.andyw.net
ErrorLog /home/bronc/logs/error_log
TransferLog /home/bronc/logs/access_log
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\""
</VirtualHost>

Additional notes:
Disabling mod_php4 and/or mod_ssl had no effect on this behaviour.

Versions: php-4.0.6-7, mod_ssl-2.8.4-9, openssl-0.9.6b-7
Comment 1 Joe Orton 2004-09-21 06:31:10 EDT
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

Comment 2 Joe Orton 2004-09-21 06:39:15 EDT
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.


Note You need to log in before you can comment on or make changes to this bug.