Bug 53973 - creating lilo.conf within kickstarting fails
creating lilo.conf within kickstarting fails
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-24 16:00 EDT by Andreas J. Bathe
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-24 16:42:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas J. Bathe 2001-09-24 16:00:48 EDT
Description of Problem:

I'm just sitting some hours to find a maybe curious error: I did
kickstarting some RH dists with creating a customized lilo.conf; but with
roswell there is something wrong:

Within the %post section I try to write a new /etc/lilo.conf after trying
to move the rh one away:

%post
[...]

# create a better (customized) /etc/lilo.conf
FILE=/etc/lilo.conf
mv $FILE $FILE.orig
cat << EOT | sed 's/X//' > $FILE
X# $FILE of $HOSTNAME
X
Xbackup=/dev/null
Xboot=/dev/md2
Xcompact
Xdefault=linux
Xinstall=/boot/boot.b
Xmap=/boot/map
Xmessage=/boot/message
Xpassword=password
Xread-only
Xrestricted
Xroot=/dev/md0
X
Ximage=/boot/vmlinuz
X       label=linux
Ximage=/boot/vmlinuz.old
X       label=linux.old
X       optional
Ximage=/boot/vmlinuz-$REDHATKERNELVERSION
X       label=linux.redhat
X       initrd=/boot/initrd-$REDHATKERNELVERSION.img
X
X# end of file.
EOT
chmod 600 $FILE ; /sbin/lilo
rm -f /boot/boot.[0-9]*

But on VC3 I only can read /etc/lilo.conf: No such file or directory ??????
although there are some lilo.conf files within /mnt/sysimage/etc:

/mnt/sysimage/etc/lilo.conf   (the kickstart one concatenated with the one
above)
/mnt/sysimage/etc/lilo.conf.rpmsave   (the customized on)

Could you please - I think it's an anaconda specific issue - give me a hint
what's going on here? We don't want to use grub in the future because we
trust the old lilo more. If it's an anaconda error, please fix that bug.
Thanx and

take care
Andreas
Comment 1 Andreas J. Bathe 2001-09-24 16:42:40 EDT
I think lilo or grub have to do all their work before entering the %post
section, otherwise you've changed the definition of the %post section of the
kickstart process.

take care
Andreas
Comment 2 Jeremy Katz 2001-09-24 17:25:49 EDT
%post was mistakenly occurring prior to the boot loader installation...  already
fixed in cvs
Comment 3 Andreas J. Bathe 2001-09-24 17:38:24 EDT
is the cvs accessible to the public yet?

Note You need to log in before you can comment on or make changes to this bug.