Bug 53985 - Neat will not run and gives errors
Neat will not run and gives errors
Status: CLOSED ERRATA
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-config-network (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-24 18:43 EDT by kingfool
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-20 03:37:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kingfool 2001-09-24 18:43:28 EDT
Description of Problem:


Version-Release number of selected component (if applicable): 0.9-1


How Reproducible: everytime 


Steps to Reproduce:
1. run neat
2. 
3. 

Actual Results:
[root@foolbox rawhide]# rpm -Uvh redhat-config-network-0.9-1.noarch.rpm  (version 0.7.x gave same errors when run)
Preparing...                ########################################### [100%]
   1:redhat-config-network  ########################################### [100%]
[root@foolbox rawhide]# neat
Copying ifcfg-eth0 to devices and putting it into the default profile.
Copying /etc/hosts to default profile.
Copying /etc/resolv.conf to default profile.
Traceback (innermost last):
  File "/usr/sbin/neat", line 1094, in ?
    window = mainDialog()
  File "/usr/sbin/neat", line 199, in __init__
    self.load()
  File "/usr/sbin/neat", line 207, in load
    self.loadDevices()
  File "/usr/sbin/neat", line 212, in loadDevices
    devicelist = getDeviceList()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCDeviceList.py", 
line 144, in getDeviceList
    DVList.load()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCDeviceList.py", 
line 59, in load
    self.data[i].load(dev)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCDevice.py", 
line 186, in load
    aliaspos = string.find(self.Device, ':')
TypeError: argument 1: expected read-only character buffer, None found


Expected Results: neat to run correctly


Additional Information:
Comment 1 Trond Eivind Glomsrxd 2001-09-24 19:32:42 EDT
What devices do you have on your system? Ethernet? Modem? ISDN?
Comment 2 kingfool 2001-09-24 19:42:53 EDT
Just a ethernet card
Comment 3 Harald Hoyer 2001-09-25 05:33:32 EDT
please attach /etc/sysconfig/network-scripts/ifcfg-eth0
Comment 4 kingfool 2001-09-25 07:36:17 EDT
DEVICE="eth0"
BOOTPROTO="none"
IPADDR="192.168.1.2"
NETMASK="255.255.255.0"
ONBOOT="yes"
IPXNETNUM_802_2=""
IPXPRIMARY_802_2="no"
IPXACTIVE_802_2="no"
IPXNETNUM_802_3=""
IPXPRIMARY_802_3="no"
IPXACTIVE_802_3="no"
IPXNETNUM_ETHERII=""
IPXPRIMARY_ETHERII="no"
IPXACTIVE_ETHERII="no"
IPXNETNUM_SNAP=""
IPXPRIMARY_SNAP="no"
IPXACTIVE_SNAP="no"
Comment 5 Ngo Than 2001-09-25 08:17:44 EDT
it works for me with your attached config file!

Are you sure that you have DEVICE=eth0 in your config file
/etc/sysconfig/network-scripts/ifcfg-eth0?

please check your config file /etc/sysconfig/network-scripts/ifcfg-eth0 again.
Comment 6 Harald Hoyer 2001-09-25 08:26:51 EDT
any other ifcfg files in /etc/sysconfig/networking/devices ???
Comment 7 kingfool 2001-09-25 14:16:46 EDT
[kingfool@foolbox devices]$ pwd
/etc/sysconfig/networking/devices
[kingfool@foolbox devices]$ ls
ifcfg-eth0  ifcfg-eth0:0

contents of ifcfg-eth0:0

IPADDR="24.190.x.x" (censored my internet address)
NETMASK=""

deleted that file because it is not needed then it works fine
Comment 8 Harald Hoyer 2001-10-16 07:09:05 EDT
fixed in cvs
Comment 9 Ngo Than 2001-11-20 04:04:14 EST
we should make errata for redhat-config-network soon.

Note You need to log in before you can comment on or make changes to this bug.