Bug 539874 - Assertion 'di->bss_size == shdr->sh_size' failed.
Summary: Assertion 'di->bss_size == shdr->sh_size' failed.
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: valgrind
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 548156 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-21 12:45 UTC by Jan Kratochvil
Modified: 2010-04-29 16:13 UTC (History)
2 users (show)

(edit)
Clone Of:
: 587338 (view as bug list)
(edit)
Last Closed: 2010-01-29 03:23:16 UTC


Attachments (Terms of Use)

Description Jan Kratochvil 2009-11-21 12:45:48 UTC
Version-Release number of selected component (if applicable):
valgrind-3.5.0-9.x86_64
gnokii-0.6.28-1.fc12.x86_64
gnokii-debuginfo-0.6.28-1.fc12.x86_64

How reproducible:
Always.

Steps to Reproduce:
valgrind gnokii 

Actual results:
==19420== Memcheck, a memory error detector
==19420== Copyright (C) 2002-2009, and GNU GPL'd, by Julian Seward et al.
==19420== Using Valgrind-3.5.0 and LibVEX; rerun with -h for copyright info
==19420== Command: gnokii
==19420== 

valgrind: m_debuginfo/readelf.c:1918 (vgModuleLocal_read_elf_debug_info): Assertion 'di->bss_size == shdr->sh_size' failed.
==19420==    at 0x3802A9B4: ??? (in /usr/lib64/valgrind/memcheck-amd64-linux)

sched status:
  running_tid=0


Note: see also the FAQ in the source distribution.
It contains workarounds to several common problems.
In particular, if Valgrind aborted or crashed after
identifying problems in your program, there's a good chance
that fixing those problems will prevent Valgrind aborting or
crashing, especially if it happened in m_mallocfree.c.

If that doesn't help, please report this bug to: www.valgrind.org

In the bug report, send all the above text, the valgrind
version, and what OS and version you are using.  Thanks.

Expected results:
No crash.

Additional info:

Comment 1 Jakub Jelinek 2009-12-02 15:38:49 UTC
Please try valgrind-3.5.0-10.fc12.

Comment 2 Jan Kratochvil 2009-12-03 17:26:50 UTC
It works great now, thanks.

Comment 3 Jakub Jelinek 2009-12-16 20:16:02 UTC
*** Bug 548156 has been marked as a duplicate of this bug. ***

Comment 4 Stefan Becker 2010-01-18 18:26:26 UTC
The update fixes the problem for me too. Can you please push it to testing?

Comment 5 Fedora Update System 2010-01-22 08:57:33 UTC
valgrind-3.5.0-14.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/valgrind-3.5.0-14.fc12

Comment 6 Fedora Update System 2010-01-22 22:39:46 UTC
valgrind-3.5.0-14.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update valgrind'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0941

Comment 7 Fedora Update System 2010-01-29 03:23:03 UTC
valgrind-3.5.0-14.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.