Bug 539956 - qemu-kvm can not boot guest
qemu-kvm can not boot guest
Status: CLOSED DUPLICATE of bug 532215
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-21 13:50 EST by Sergei LITVINENKO
Modified: 2009-11-22 10:11 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-22 10:11:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergei LITVINENKO 2009-11-21 13:50:57 EST
Description of problem:
kvm: unhandled exit 7
kvm_run returned -22

Version-Release number of selected component (if applicable):
[sergeil@homedesk ~]$ rpm -qf `which qemu-kvm`
qemu-system-x86-0.11.0-11.fc12.i686

How reproducible:
100%

Steps to Reproduce:
1. qemu-kvm -localtime -hda rawhide.img -boot c -m 1024
2.
3.
  
Actual results:
error message and stop guest booting after message
ata0 master ...

Expected results:
boot guest system and work

Additional info:

1. `qemu-kvm -no-kvm -hda fedora12.img -boot c` work as expected

2. [sergeil@homedesk ~]$ uname -r
   2.6.31.5-127.fc12.i686.PAE

3. [sergeil@homedesk ~]$ cat /proc/cpuinfo | grep "model name"
...
model name      : Intel(R) Core(TM)2 Duo CPU     E6850  @ 3.00GHz
...

4. Disk image is created and work OK under Fedora-11
Comment 1 Sergei LITVINENKO 2009-11-21 14:20:45 EST
rebuild and installing qemu-0.11.0-12.fc13.src.rpm from rawhide decided my problem.
Comment 2 Justin M. Forbes 2009-11-22 10:11:59 EST
This is actually a KSM issue that only appears when running on a 32bit host.  Using the kernel update from updates-testing will resolve the issue.  You can also 'service ksmtuned stop; service ksm stop' after the system has booted to temporarily restore functionality until the new kernel is shipping.

*** This bug has been marked as a duplicate of bug 532215 ***

Note You need to log in before you can comment on or make changes to this bug.