Bug 540310 - Network error when sharing pulseaudio sources to a PS3
Summary: Network error when sharing pulseaudio sources to a PS3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rygel
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 538622 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-23 01:26 UTC by Robert Marcano
Modified: 2009-12-24 04:01 UTC (History)
2 users (show)

Fixed In Version: 0.5.0-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-22 04:57:43 UTC


Attachments (Terms of Use)

Description Robert Marcano 2009-11-23 01:26:34 UTC
Description of problem:

Tryng to use the new feature to share pulseaudio sources to the PS3 gives one error on the PS3 or a crash on rygel

Version-Release number of selected component (if applicable):
rygel-0.4.2-1.fc12.x86_64
pulseaudio-0.9.19-2.fc12.x86_64

How reproducible:
Always


Steps to Reproduce:
1.Load pulse audio rygel module with: "pactl load-module module-rygel-media-server"
2.Start "rygel"
3.Go the the PS3 XMP Music icon for the "Audio on $hostname" media server
4.Select "Output Devices -> Internal Audio Analog Stereo"
5.Select "Input Devices"
  
Actual results:

When selecting "Output Devices -> Internal Audio Analog Stereo" the PS3 signals the error "a network error has ocurred (871053D)"

When selecting "Input Devices" rygel crahes with the error:

** (rygel:20719): CRITICAL **: gee_array_list_real_slice: assertion `stop <= self->priv->_size' failed
Segmentation fault (core dumped)

Expected results:

Hear the computer audio on the PS3 output device


Additional info:

The problem was verified on both wireless and wired interfaces. Using default file generated by rygel-properties. playback of files fron rygel directly work without problems

Comment 1 Robert Marcano 2009-11-23 01:27:19 UTC
Forgot to mention the PS3 is using latest firmware 3.10

Comment 2 Peter Robinson 2009-11-23 03:43:57 UTC
*** Bug 538622 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2009-12-09 21:34:04 UTC
libgee-0.5.0-1.fc12,rygel-0.4.6-1.fc12,gupnp-vala-0.6.2-1.fc12,gupnp-igd-0.1.5-1.fc12,shotwell-0.3.2-3.fc12,gupnp-av-0.5.2-1.fc12,gupnp-0.13.2-1.fc12,gssdp-0.7.1-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libgee-0.5.0-1.fc12,rygel-0.4.6-1.fc12,gupnp-vala-0.6.2-1.fc12,gupnp-igd-0.1.5-1.fc12,shotwell-0.3.2-3.fc12,gupnp-av-0.5.2-1.fc12,gupnp-0.13.2-1.fc12,gssdp-0.7.1-1.fc12

Comment 4 Fedora Update System 2009-12-11 18:28:22 UTC
libgee-0.5.0-1.fc12, rygel-0.4.6-1.fc12, gupnp-vala-0.6.2-1.fc12, gupnp-igd-0.1.5-1.fc12, shotwell-0.3.2-3.fc12, gupnp-av-0.5.2-1.fc12, gupnp-0.13.2-1.fc12, gssdp-0.7.1-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libgee rygel gupnp-vala gupnp-igd shotwell gupnp-av gupnp gssdp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13105

Comment 5 Fedora Update System 2009-12-16 01:21:54 UTC
libgee-0.5.0-1.fc12, rygel-0.4.6-1.fc12, gupnp-vala-0.6.2-1.fc12, shotwell-0.3.2-3.fc12, gupnp-av-0.5.2-1.fc12, gupnp-0.13.2-1.fc12, gssdp-0.7.1-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libgee rygel gupnp-vala shotwell gupnp-av gupnp gssdp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13105

Comment 6 Fedora Update System 2009-12-22 04:57:20 UTC
libgee-0.5.0-1.fc12, rygel-0.4.6-1.fc12, gupnp-vala-0.6.2-1.fc12, shotwell-0.3.2-3.fc12, gupnp-av-0.5.2-1.fc12, gupnp-0.13.2-1.fc12, gssdp-0.7.1-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Robert Marcano 2009-12-23 19:26:51 UTC
I request this bug to be reopened, the updates fixes the reported crash, but not the real problem explained on comment #1, now rygel do not crash but it says a new kind of "a network error has occurred (80710003)" when using the

XMB options: "Audio on $hostname" media server -> "Output Devices" or "Input Devices"

This "fix" broke basic sharing without the pulseaudio module, so before the update playing files from "$username's media" XMB icon worked, it now says the same "A network error has accurred. (80710003)" so the problems is caused by this "fix"

just a simple question, is someone testing it rygel with a PS3, because that is the impression users get when you see the F12 announcement with the following words

"Integration with the Rygel UPnP media server means you can stream audio directly from your system to any UPnP / DLNA client, such as a Playstation 3."

and I have been unable to use thet supposed integration, I offer any help to test it better with the PS3 (network trace???)

Comment 8 Peter Robinson 2009-12-23 22:24:37 UTC
> and I have been unable to use thet supposed integration, I offer any help to
> test it better with the PS3 (network trace???)  

A further issue was discovered just after 0.4.6 was released with the PS3 in particular because of the way it implements upnp. This has been fixed in 0.4.8 which is now is updates-testing. Please test that and update this bug before we reopen it. Release notes:
http://lists.o-hand.com/gupnp/0848.html

Comment 9 Robert Marcano 2009-12-24 04:01:21 UTC
0.4.8 fixes the previously working file playback, still unable to use the pulseaudio / rygel integration. When the bug was reported, rygel crashed, now the PS3 show: "a network error has occurred (80710003)"


Note You need to log in before you can comment on or make changes to this bug.