Bug 540489 - RFE: please remove status column from yum repolist enabled/disabled
RFE: please remove status column from yum repolist enabled/disabled
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-23 09:07 EST by Karel Volný
Modified: 2014-01-21 18:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-29 16:49:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2009-11-23 09:07:56 EST
Description of problem:
the subject says that all - yum repolist does not list repositories that are not enabled

Version-Release number of selected component (if applicable):
yum-3.2.25-1.fc12.noarch

How reproducible:
always

Steps to Reproduce:
1. yum repolist
  
Actual results:
Loaded plugins: refresh-packagekit                                                    
repo id                   repo name                                     status
adobe-linux-i386          Adobe Systems Incorporated                    enabled:    17
fedora                    Fedora 12 - x86_64                            enabled: 19122
kde                       kde                                           enabled:     3
kde-testing               kde-testing                                   enabled:   141
rhts                      Red Hat Test Suite - x86_64 - Base            enabled:   161
rpmfusion-free            RPM Fusion for Fedora 12 - Free               enabled:   432
rpmfusion-free-updates    RPM Fusion for Fedora 12 - Free - Updates     enabled:     1
rpmfusion-nonfree         RPM Fusion for Fedora 12 - Nonfree            enabled:   139
rpmfusion-nonfree-updates RPM Fusion for Fedora 12 - Nonfree - Updates  enabled:     0
updates                   Fedora 12 - x86_64 - Updates                  enabled:   755
repolist: 20771


Expected results:
Loaded plugins: refresh-packagekit
repo id                                     repo name                   status
adobe-linux-i386                            Adobe Systems Incorporated  enabled:    17
fedora                                      Fedora 12 - x86_64          enabled: 19122
fedora-debuginfo                            Fedora 12 - x86_64 - Debug  disabled:  4928
fedora-source                               Fedora 12 - Source          disabled:  8518
kde                                         kde                         enabled:     3
kde-testing                                 kde-testing                 enabled:   141
kde-unstable                                kde-unstable                disabled:    85
rawhide                                     Fedora - Rawhide - Developm disabled: 19395
rawhide-debuginfo                           Fedora - Rawhide - Debug    disabled:  4970
rawhide-source                              Fedora - Rawhide - Source   disabled:  8639
rhts                                        Red Hat Test Suite - x86_64 enabled:   161
rhts-noarch                                 RedHatEnterpriseLinuxServer disabled:  6281
rhts-testing                                Red Hat Test Suite - x86_64 disabled:   123
rpmfusion-free                              RPM Fusion for Fedora 12 -  enabled:   432
rpmfusion-free-debuginfo                    RPM Fusion for Fedora 12 -  disabled:   158
rpmfusion-free-rawhide                      RPM Fusion for Fedora Rawhi disabled:   447
rpmfusion-free-rawhide-debuginfo            RPM Fusion for Fedora Rawhi disabled:   163
rpmfusion-free-rawhide-source               RPM Fusion for Fedora Rawhi disabled:   186
rpmfusion-free-source                       RPM Fusion for Fedora 12 -  disabled:   181
rpmfusion-free-updates                      RPM Fusion for Fedora 12 -  enabled:     1
rpmfusion-free-updates-debuginfo            RPM Fusion for Fedora 12 -  disabled:     1
rpmfusion-free-updates-source               RPM Fusion for Fedora 12 -  disabled:     1
rpmfusion-free-updates-testing              RPM Fusion for Fedora 12 -  disabled:    59
rpmfusion-free-updates-testing-debuginfo    RPM Fusion for Fedora 12 -  disabled:    13
rpmfusion-free-updates-testing-source       RPM Fusion for Fedora 12 -  disabled:    16
rpmfusion-nonfree                           RPM Fusion for Fedora 12 -  enabled:   139
rpmfusion-nonfree-debuginfo                 RPM Fusion for Fedora 12 -  disabled:    45
rpmfusion-nonfree-rawhide                   RPM Fusion for Fedora Rawhi disabled:   143
rpmfusion-nonfree-rawhide-debuginfo         RPM Fusion for Fedora Rawhi disabled:    48
rpmfusion-nonfree-rawhide-source            RPM Fusion for Fedora Rawhi disabled:    72
rpmfusion-nonfree-source                    RPM Fusion for Fedora 12 -  disabled:    69
rpmfusion-nonfree-updates                   RPM Fusion for Fedora 12 -  enabled:     0
rpmfusion-nonfree-updates-debuginfo         RPM Fusion for Fedora 12 -  disabled:     0
rpmfusion-nonfree-updates-source            RPM Fusion for Fedora 12 -  disabled:     0
rpmfusion-nonfree-updates-testing           RPM Fusion for Fedora 12 -  disabled:    44
rpmfusion-nonfree-updates-testing-debuginfo RPM Fusion for Fedora 12 -  disabled:    16
rpmfusion-nonfree-updates-testing-source    RPM Fusion for Fedora 12 -  disabled:    17
updates                                     Fedora 12 - x86_64 - Update enabled:   755
updates-debuginfo                           Fedora 12 - x86_64 - Update disabled:   135
updates-source                              Fedora 12 - Updates Source  disabled:   192
updates-testing                             Fedora 12 - x86_64 - Test U disabled:   928
updates-testing-debuginfo                   Fedora 12 - x86_64 - Test U disabled:   184
updates-testing-source                      Fedora 12 - Test Updates So disabled:   251
repolist: 77079


Additional info:
Comment 1 James Antill 2009-11-23 09:57:54 EST
Run: "yum repolist all"

Or, even: yum --enablerepo=\* repolist

Displaying all repos by default is way more info. than most people want (a lot more than a screen in your case) ... just displaying "what repos. am I using atm." is often the desired behaviour, and often fits on a screen.
Comment 2 Karel Volný 2009-11-23 10:18:53 EST
um, okay, too little RTFM, I haven't noticed what the manpage says, I just relied on the builtin help

so, if that is desired then I change this to RFE, because the current behaviour does not make any sense to me and led me to thinking it is a bug ...

if only enabled/disabled repositories are listed, it is superfluous to add the information about the status (especially if you are so concerned about the screen space :-))

in addition, if yum defaults to enabled then it would be nice if the user is warned about that, like prepending one line at the top "Listing enabled/disabled/all repositories"
Comment 4 Karel Volný 2009-12-02 04:49:46 EST
(In reply to comment #3)
> This just went upstream:
> 
> http://yum.baseurl.org/gitweb?p=yum.git;a=commitdiff;h=4aa1a6639a1544bc714b75b61d5cbf9d5ce34fc3  

thanks, looks nice, as far as I understand the code ;-)
Comment 5 James Antill 2010-04-29 16:49:40 EDT
This should be in the latest F-12 update.

Note You need to log in before you can comment on or make changes to this bug.