Bug 540647 - SATA HDD not being recognized in Fedora 12 64-bit for my machine
SATA HDD not being recognized in Fedora 12 64-bit for my machine
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-23 16:08 EST by Jaideep Khandelwal
Modified: 2010-12-03 21:53 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-03 21:53:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaideep Khandelwal 2009-11-23 16:08:41 EST
Description of problem: SATA HDD not being recognized

I am using ASUS A8V-MX VIA K8M800 Mother Board with AMD ATHLON 3200+ 64-bit.
I have two HDD: 
  1.) SAMSUNG PATA (IDE) 80 GB (For Booting Fedora 12)
  2.) SEAGATE SATA 250 GB ( As storage drive)

I upgraded from Fedora 10 to Fedora 12 using preupgrade

This is the description of IDE interface:
IDE interface: VIA Technologies, Inc. VT8251 AHCI/SATA 4-Port Controller
IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/
 
The '/' and swap mount point is in PATA HDD.

I can boot into Fedora 12 , but now Fedora 12 does not recognize the SATA HDD.
It gives an error at the boot time. Here is the dmesg output ( The error portion only !)
 
http://jaideep.fedorapeople.org/dmesgcut.txt

 

Version-Release number of selected component (if applicable): 
 2.6.31.5-127.fc12.x86_64
 


How reproducible: 1.) I tried to install F11 and F12 from DVD Media , the installer also didn not recognize my SATA HDD.

2.) Tried with F11 & Ubuntu 9.04 live disk , the SATA HDD is not being recognized in live sessions as well. 

3.) Checked the BIOS settings , their is no issue as such from BIOS.
4.) Checked the SATA HDD by attaching to different machine , its working fine.
5.) I checked over Xp Machines, where it is being recognized [ Didn't wanted to do it but the last I had to :( ] 

Steps to Reproduce:
1. Output : fdisk -l

   Disk /dev/sda: 80.1 GB, 80060424192 bytes
255 heads, 63 sectors/track, 9733 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x22222222

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        2550    20482843+   c  W95 FAT32 (LBA)
/dev/sda2   *        2551        9179    53247442+  83  Linux
/dev/sda3            9180        9689     4096575   82  Linux swap / Solaris
/dev/sda4            9690        9733      353430    5  Extended

 
2. Output: cat /proc/scsi/scsi
 
 Attached devices:
 Host: scsi4 Channel: 00 Id: 01 Lun: 00
  Vendor: ATA      Model: SAMSUNG SP0822N  Rev: WA10
  Type:   Direct-Access                    ANSI  SCSI revision: 05

3. Output: find /dev/disk

/dev/disk/
/dev/disk/by-label
/dev/disk/by-label/\x15\xa0\x10C\x5c\x8b\xf8\x85\xfft
/dev/disk/by-label/\x2f
/dev/disk/by-label/SWAP-sda3
/dev/disk/by-uuid
/dev/disk/by-uuid/201D-2A1B
/dev/disk/by-uuid/ca80ce88-93e0-4995-8c23-4278a6df2417
/dev/disk/by-uuid/5d702253-ac40-4878-8356-2a0b034c2fcd
/dev/disk/by-path
/dev/disk/by-path/pci-0000:00:0f.1-scsi-0:0:1:0-part1
/dev/disk/by-path/pci-0000:00:0f.1-scsi-0:0:1:0-part2
/dev/disk/by-path/pci-0000:00:0f.1-scsi-0:0:1:0-part3
/dev/disk/by-path/pci-0000:00:0f.1-scsi-0:0:1:0-part4
/dev/disk/by-path/pci-0000:00:0f.1-scsi-0:0:1:0
/dev/disk/by-id
/dev/disk/by-id/scsi-SATA_SAMSUNG_SP0822NS06QJ10Y781247-part1
/dev/disk/by-id/ata-SAMSUNG_SP0822N_S06QJ10Y781247-part1
/dev/disk/by-id/scsi-SATA_SAMSUNG_SP0822NS06QJ10Y781247-part2
/dev/disk/by-id/ata-SAMSUNG_SP0822N_S06QJ10Y781247-part2
/dev/disk/by-id/scsi-SATA_SAMSUNG_SP0822NS06QJ10Y781247-part3
/dev/disk/by-id/ata-SAMSUNG_SP0822N_S06QJ10Y781247-part3
/dev/disk/by-id/scsi-SATA_SAMSUNG_SP0822NS06QJ10Y781247-part4
/dev/disk/by-id/ata-SAMSUNG_SP0822N_S06QJ10Y781247-part4
/dev/disk/by-id/scsi-SATA_SAMSUNG_SP0822NS06QJ10Y781247
/dev/disk/by-id/ata-SAMSUNG_SP0822N_S06QJ10Y781247


  
Actual results: The SATA HDD not being identified.


Expected results: The SATA HDD should be identified 


Additional info: The problem that I found is occurring with Linux Kernel 
2.6.29.4-167.fc11.x86_64
2.6.28-11.37(for ubuntu)

As my machine can not at identify , I dont have much additional info but here is the complete output of dmesg

http://jaideep.fedorapeople.org/dmesg.txt
Comment 1 Jaideep Khandelwal 2009-11-24 11:21:25 EST

> Additional info: The problem that I found is occurring with Linux Kernel 
> 2.6.29.4-167.fc11.x86_64
> 2.6.28-11.37(for ubuntu)
> 
 
I tried Fedora 10 live cd , where it detected my SATA HDD . What I suspect is that Linux Kernel has switched to SATA subsytem from IDE subsystem, and this might be kernel regression . Here are the logs for dmesg while I booted from Fedora 10 live cd:

[1] http://jaideep.fedorapeople.org/dmesgf10live.txt

Output of " cat /proc/scsi/scsi ":

[2] http://jaideep.fedorapeople.org/scsif10live.txt

Output of " find /dev/disk "

[3] http://jaideep.fedorapeople.org/devf10live.txt

What I found was that it is working fine with kernel 

2.6.27.37-170.2.104.fc10.x86_64
Comment 2 Jaideep Khandelwal 2009-12-13 04:35:21 EST
Here is the log report for the smoltSendProfile:

http://jaideep.fedorapeople.org/smoltSendProfile
Comment 3 Michal Schmidt 2010-02-08 10:46:28 EST
Please try booting with "pci=nomsi". Does it make any difference?
Comment 4 Jaideep Khandelwal 2010-02-08 22:30:17 EST
(In reply to comment #3)
> Please try booting with "pci=nomsi". Does it make any difference?    

Michal Schmidt , it worked man , now the HDD could be recognized
Comment 5 Bug Zapper 2010-11-04 01:34:33 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2010-12-03 21:53:39 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.