This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 5407 - ldconfig -D reports numerous errors
ldconfig -D reports numerous errors
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ldconfig (Show other bugs)
6.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-27 16:41 EDT by m.reid
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-04 22:26:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description m.reid 1999-09-27 16:41:01 EDT
Running ldconfig -D on several systems (I have tried at
least three) that have RedHat 6.0 installed gives numerous
error messages, such as the following:

ldconfig: warning:
/usr/i486-linux-libc5/lib/libpanel.so.1.9.9e has
inconsistent soname (libpanel.so.3.0)
... a few screens ...
ldconfig: warning: /lib/libpthread-0.8.so has inconsistent
soname (libpthread.so.0)
ldconfig: warning: /lib/libresolv-2.1.1.so has inconsistent
soname (libresolv.so.2)
ldconfig: warning: /lib/librt-2.1.1.so has inconsistent
soname (librt.so.1)
ldconfig: warning: /lib/libutil-2.1.1.so has inconsistent
soname (libutil.so.1)

Since these systems all appear to work fine, and I have not
been able to find a system that does not have this
behaviour, I assume that there is no cause for alarm.

However, it is rather disconcerting to see this when one is
trying to resolve problems with dependencies...
Comment 1 Cristian Gafton 2000-02-04 22:26:59 EST
This is normal behavior. ldconfig has a very strict (and not always right) idea
about how a soname should look like.

Note You need to log in before you can comment on or make changes to this bug.