Bug 54073 - can't see national characters with new glibc
can't see national characters with new glibc
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-26 16:54 EDT by Stas Sergeev
Modified: 2016-11-24 10:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-18 17:53:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stas Sergeev 2001-09-26 16:54:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.19 i686)

Description of problem:
After upgrading to glibc-2.2.2-10, Cyrillic characters no longer
displaying in sawfish. There are question marks instead. All other
programs seems to be unaffected, only sawfish is broken.
Window headers, sawfish menu, sawfish configurator etc, all have
question marks now instead of letters.

Version-Release number of selected component (if applicable):
2.2.2-10

How reproducible:
Always

Steps to Reproduce:
1. rpm -U glibc-*2.2.2-10.i386.rpm
2. set koi8-r locale
3. start gnome/sawfish
4. click middle mouse button on the desktop to envoke sawfish menu...
5. try to read something from there:)

Actual Results:  Question marks instead of the Cyrillic characters in
sawfish.

Expected Results:  Cyrillic characters in sawfish and everywhere else as
well:)

Additional info:

I don't think it is a misconfiguration, because downgrading back
to glibc-2.2-5 solves the problem. Unfortunately I have to do so
to work around this problem.

My locale settings:

LANG=ru
LC_CTYPE="ru_RU.KOI8-R"
LC_NUMERIC="ru_RU.KOI8-R"
LC_TIME="ru_RU.KOI8-R"
LC_COLLATE="ru_RU.KOI8-R"
LC_MONETARY="ru_RU.KOI8-R"
LC_MESSAGES="ru_RU.KOI8-R"
LC_PAPER="ru_RU.KOI8-R"
LC_NAME="ru_RU.KOI8-R"
LC_ADDRESS="ru_RU.KOI8-R"
LC_TELEPHONE="ru_RU.KOI8-R"
LC_MEASUREMENT="ru_RU.KOI8-R"
LC_IDENTIFICATION="ru_RU.KOI8-R"
LC_ALL=ru_RU.KOI8-R
Comment 1 Jakub Jelinek 2001-10-18 04:55:55 EDT
Please try the errata packages (glibc-2.2.4-19).
Comment 2 Stas Sergeev 2001-10-18 17:53:41 EDT
Updated only glibc and glibc-common (too long to download, but hope it is
enough) to 2.2.4-19. Still the same problem:(
Downgraded back to 2.2-5 for now.
Comment 3 Stas Sergeev 2002-02-04 15:34:04 EST
Upgrading to RH7.2 solves the problem. So this was only on 7.1. I don't know
which
package exactly fixes this, maybe sawfish itself...

Note You need to log in before you can comment on or make changes to this bug.