Bug 540802 - ssh: FATAL: Unknown option -2
ssh: FATAL: Unknown option -2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Jan F. Chadima
Fedora Extras Quality Assurance
:
: 540604 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-24 02:23 EST by Wolfgang Rapp
Modified: 2010-06-07 04:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-07 04:50:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wolfgang Rapp 2009-11-24 02:23:34 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.1.5) Gecko/20091105 Fedora/3.5.5-1.fc12 Firefox/3.5.5

nxclient try to establish connection ends with 

ssh: FATAL: Unknown option -2



Reproducible: Always

Steps to Reproduce:
1.setup freenx-server on F12
2.connect with nxclient from other machine
3.Also reproducable local without nx only by typ in p.e.
  ssh -l root localhost -2
  
Actual Results:  
ssh: FATAL: Unknown option -2

Expected Results:  
should do ssh login without errors

openssh-5.2p1-31.fc12.i686
freenx-server-0.7.3-15.fc12.i686
Comment 1 Jan F. Chadima 2009-11-24 04:14:12 EST
Can you trace the other conditions, which may cause the problem. I've tried run ssh -l root localhost -2 on frshly installed F12 without the problem.
Comment 2 Jan F. Chadima 2009-11-24 04:17:25 EST
*** Bug 540604 has been marked as a duplicate of this bug. ***
Comment 3 Wolfgang Rapp 2009-12-09 05:16:48 EST
(In reply to comment #2)
> *** Bug 540604 has been marked as a duplicate of this bug. ***  

(In reply to comment #1)
> Can you trace the other conditions, which may cause the problem. I've tried run
> ssh -l root localhost -2 on frshly installed F12 without the problem.  

Works after removing and new installation of ssh. Seems to be a problem of update procedure from earlier versions.(In reply to comment #1)
> Can you trace the other conditions, which may cause the problem. I've tried run
> ssh -l root localhost -2 on frshly installed F12 without the problem.

Note You need to log in before you can comment on or make changes to this bug.