Bug 54089 - ttmkfdir error with CJK fonts
ttmkfdir error with CJK fonts
Status: CLOSED DUPLICATE of bug 54087
Product: Red Hat Public Beta
Classification: Retired
Component: freetype (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-27 06:35 EDT by Won-kyu Park
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-27 06:36:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Won-kyu Park 2001-09-27 06:35:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
ttmkfdir can't produce font.dir correctly with CJK fonts in ttfonts-ja 
ttfonts-ko.

It may seems to me a ttmkfdir2 have some bug.

I make a patch againt ttmkfdir2, It work correctly for me now.

-------------8X--------------------
--- ttmkfdir2/encoding.l	Thu Jan 13 07:17:46 2000
+++ ttmkfdir2.my/encoding.l	Thu Sep 27 18:36:32 2001
@@ -62,7 +62,7 @@
     
     i2 = std::strtol (startptr, &endptr, 0);
 
-    cur_enc->size = (startptr == endptr) ? i1 : (i1 << 8) + i2;
+    cur_enc->size = (startptr == endptr) ? i1 - 1: (i1 - 1 << 8) + i2;
 }
 
 <INSIDE_ENC_BLOCK>STARTMAPPING{WHITESPACES}unicode {
--------------------- 8X-----------------

And I have also found some encoding map bug "gbk-0.enc"
in XFree86-4.x.x

if you change the UNDIFINE section like following

- UNDIFINE 0 0xFFFF
+ UNDIFINE 0 0xFEFE

working correctly with above patched ttmkfdir.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.cp /usr/share/fonts/ko/TrueType/gulim.ttf .
2.ttmkfdir

font.dir have incorrect information. !

ttmkfdir will not working with CJK fonts.
	

Additional info:
Comment 1 Won-kyu Park 2001-09-27 06:39:48 EDT

*** This bug has been marked as a duplicate of 54087 ***

Note You need to log in before you can comment on or make changes to this bug.