Bug 541050 - GCL segmentation fault
Summary: GCL segmentation fault
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gcl
Version: 11
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jerry James
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-24 20:31 UTC by Michael Rice
Modified: 2009-12-10 04:28 UTC (History)
2 users (show)

Fixed In Version: 2.6.8-0.7.20090701cvs.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-10 04:12:54 UTC
Type: ---


Attachments (Terms of Use)
Copied this from SELinux troubleshoot browser (3.41 KB, text/plain)
2009-11-24 20:31 UTC, Michael Rice
no flags Details

Description Michael Rice 2009-11-24 20:31:40 UTC
Created attachment 373522 [details]
Copied this from SELinux troubleshoot browser

Description of problem:

[michael@localhost ~]$ gcl
Segmentation fault
[michael@localhost ~]$

Also getting SELinux complaint (see attachment) 


Version-Release number of selected component (if applicable):
gcl-2.6.8-0.4.20090701cvs.fc11 (i586)

How reproducible: See description of problem above.


Steps to Reproduce:
1. See description of problem above.
2.
3.
  
Actual results: See description of problem above.


Expected results:


Additional info:

Comment 1 Jerry James 2009-11-24 21:22:31 UTC
I need more information.  Neither the segfault nor the AVC denial occur on my F-11 system.  Can you show me the output of "ls -Z /usr/lib/gcl-2.6.8/unixport"?

Comment 2 Michael Rice 2009-11-24 21:30:42 UTC
No problem.

Michael

[michael@localhost ~]$ ls -Z /usr/lib/gcl-2.6.8/unixport
-rw-r--r--. root root system_u:object_r:lib_t:s0       init_ansi_gcl.lsp
-rw-r--r--. root root system_u:object_r:lib_t:s0       libansi_gcl.a
-rw-r--r--. root root system_u:object_r:lib_t:s0       libgclp.a
-rwxr-xr-x. root root system_u:object_r:lib_t:s0       saved_ansi_gcl
[michael@localhost ~]$

Comment 3 Jerry James 2009-11-24 21:49:51 UTC
Do you have the gcl-selinux package installed?  It should have taken care of giving saved_ansi_gcl the correct SELinux type, which is gcl_exec_t, not lib_t.  Does running this:

  semodule -l | grep gcl

as a privileged user produce output ("gcl     1.0.1")?  If so, does

  /sbin/fixfiles -R gcl restore

(again, as a privileged user) change the type of saved_ansi_gcl to gcl_exec_t?

Comment 4 Michael Rice 2009-11-24 22:05:57 UTC
[michael@localhost ~]$ su
Password: 
[root@localhost michael]# semodule -l | grep gcl
gcl	1.0.1
[root@localhost michael]#

How do I check the type of saved_ansi_gcl?

Michael

Comment 5 Jerry James 2009-11-24 22:12:39 UTC
Sorry, I'll provide more detail.  First is gcl-selinux installed?

The -Z switch to ls shows the type, like what you pasted into comment 2.  Try running the fixfiles command from comment 3, then run ls -Z again to see if it had the desired effect.

Did you install GCL with SELinux turned off, then later turn SELinux on?  (I'm trying to come up with a scenario where the SELinux type gets erased or not set properly in the first place.)

Comment 6 Michael Rice 2009-11-24 22:35:23 UTC
I installed with the Administration|Add/Remove Software and it added one extra package that I think was gcl-selinux.

Whatever SELinux was for the Fedora 11 installation is what it still is. I made NO changes. Never turned it off. I did load CLISP (months ago) and SBCL (weeks ago) if that makes any difference.

[michael@localhost ~]$ su
Password: 
[root@localhost michael]# semodule -l | grep gcl
gcl	1.0.1
[root@localhost michael]# man ls
Formatting page, please wait...
[root@localhost michael]# /sbin/fixfiles -R gcl restore
[root@localhost michael]# ls -Z /usr/lib/gcl-2.6.8/unixport
-rw-r--r--. root root system_u:object_r:lib_t:s0       init_ansi_gcl.lsp
-rw-r--r--. root root system_u:object_r:lib_t:s0       libansi_gcl.a
-rw-r--r--. root root system_u:object_r:lib_t:s0       libgclp.a
-rwxr-xr-x. root root system_u:object_r:gcl_exec_t:s0  saved_ansi_gcl
[root@localhost michael]# 

This isn't critical for me. I just tried to install to have a look at GCL and SELinux recommended filing with Bugzilla.

Michael

Comment 7 Jerry James 2009-11-24 22:42:36 UTC
Well, saved_ansi_gcl has the right type now, so the segfault and AVC denial should be gone.  I'll have to try a few installation scenarios to see if I can figure out how it got installed on your machine with an incorrect type.  In any case, you should be good to go now.

Comment 8 Michael Rice 2009-11-24 22:52:34 UTC
Just remembered: I tried loading Slime (http://common-lisp.net/project/slime/) and McClim (http://common-lisp.net/project/mcclim/) after SBCL, but the install was less than completely successful, though I don't remember any SELinux objections.

I have a Fedora 12 Install DVD. Should I hold off installing till you puzzle this out?

Michael

Comment 9 Jerry James 2009-11-24 23:03:42 UTC
No, go ahead.  If you have the same problem, please post to this bug.  I'm planning to install Fedora 12 myself tonight.  I'll see if I can reproduce the problem.

Comment 10 Michael Rice 2009-11-25 05:20:56 UTC
Looks like the problem followed me to F12.

It runs after fixfile in both F11 and F12 (see below).

I used a default install and then ran autoten to get Flash and codecs.

Then I downloaded GCL with Add/Remove Software.

Michael

=========

[michael@localhost ~]$ gcl
Segmentation fault (core dumped)
[michael@localhost ~]$ su
Password: 
[root@localhost michael]# semodule -l | grep gcl
gcl	1.0.1	
[root@localhost michael]# ls -Z /usr/lib/gcl-2.6.8/unixport
-rw-r--r--. root root system_u:object_r:lib_t:s0       init_ansi_gcl.lsp
-rw-r--r--. root root system_u:object_r:lib_t:s0       libansi_gcl.a
-rw-r--r--. root root system_u:object_r:lib_t:s0       libgclp.a
-rwxr-xr-x. root root system_u:object_r:lib_t:s0       saved_ansi_gcl
[root@localhost michael]# /sbin/fixfiles -R gcl restore
[root@localhost michael]# ls -Z /usr/lib/gcl-2.6.8/unixport
-rw-r--r--. root root system_u:object_r:lib_t:s0       init_ansi_gcl.lsp
-rw-r--r--. root root system_u:object_r:lib_t:s0       libansi_gcl.a
-rw-r--r--. root root system_u:object_r:lib_t:s0       libgclp.a
-rwxr-xr-x. root root system_u:object_r:gcl_exec_t:s0  saved_ansi_gcl
[root@localhost michael]# gcl
GCL (GNU Common Lisp)  2.6.8 ANSI    Oct 20 2009 18:30:33
Source License: LGPL(gcl,gmp), GPL(unexec,bfd,xgcl)
Binary License:  GPL due to GPL'ed components: (XGCL READLINE BFD UNEXEC)
Modifications of this banner must retain notice of a compatible license
Dedicated to the memory of W. Schelter

Use (help) to get some basic information on how to use GCL.
Temporary directory for compiler files set to /tmp/

>(car '(a b c))

A

>(quit)
[root@localhost michael]#

Comment 11 Jerry James 2009-11-25 16:30:09 UTC
Yes, I reproduced this with my F-12 install.  I still don't understand why it is happening, though.  Investigating....

Comment 12 Fedora Update System 2009-11-30 20:31:22 UTC
gcl-2.6.8-0.7.20090701cvs.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gcl-2.6.8-0.7.20090701cvs.fc12

Comment 13 Fedora Update System 2009-11-30 20:31:32 UTC
gcl-2.6.8-0.5.20090701cvs.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gcl-2.6.8-0.5.20090701cvs.fc11

Comment 14 Fedora Update System 2009-12-02 04:28:38 UTC
gcl-2.6.8-0.7.20090701cvs.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gcl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12489

Comment 15 Fedora Update System 2009-12-02 04:43:22 UTC
gcl-2.6.8-0.5.20090701cvs.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gcl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-12507

Comment 16 Fedora Update System 2009-12-10 04:12:44 UTC
gcl-2.6.8-0.5.20090701cvs.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2009-12-10 04:28:05 UTC
gcl-2.6.8-0.7.20090701cvs.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.