Bug 54134 - Installer crashes when starting graphical mode
Installer crashes when starting graphical mode
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-28 05:49 EDT by John Airey
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-15 18:14:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Airey 2001-09-28 05:49:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT; DigExt)

Description of problem:
I cannot get the RedHat 7.1 installer to install in graphical mode on a 
Dell Poweredge 5166-2 that uses an ATI Mach64 card with 1MB memory. It has 
an onboard SymBIOS SCSI card and an Adaptec 2940 card with an ST32550N 
disk on each SCSI card. It is fitted with a standard keyboard and MS 
intellimouse.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert CD and boot floppy
2. Use either expert mode or press enter
3. Wait
	

Actual Results:  Running anaconda - please wait...
Probing for mouse type...
Waiting for X server to start...log located in /tmp/X.log
... X server started successfully.
Gdk-ERROR **: Fatal IO error 104 (Connection reset by peer) on X server :1.
install exited abnormally
sending termination signals ... done
sending kill signals ... done
disabling swap ...
unmounting filesystems ...
   /mnt/runtime
   /mnt/source umount failed ()
   /dev/pts
   /proc
you may safely reboot your system

Expected Results:  I should have been able to get into the graphical 
installer.

Additional info:

I have tried this with a RedHat 7.1 evaluation CD that was given to me at 
Linux Expo. I have tried installing off an ISO image on a hard disk, but 
of course this will not run in graphical mode. I've created CDs from these 
ISO images using EasyCD creator and Nero, but again the same result occurs 
(however, the "MD5sum" of these CDs does not match the ISO images)

I need to be able to install in graphical mode as that is the only way to 
set up software RAID.

I can install RedHat 6.2 in graphical mode, and upgrade to 7.1, but this 
shows all kinds of errors in the upgrade log. I have been trying the vga= 
options also to no avail.

I am in the process of purchasing the full version of RedHat 7.1 to test 
this further.
Comment 1 Brent Fox 2001-09-28 12:17:40 EDT
I'd be curious to know if the retail version works.  There's no reason that the
evaluation cd's shouldn't work, though.  Although it sounds like the cd's you
burned from the ISO's may not have the same md5sums as the original ISO's.  That
would pretty much guarantee that they wouldn't work.

If the graphical installer won't work, there's always text mode, which should
get you an installed system.
Comment 2 John Airey 2001-10-01 04:20:30 EDT
I think you missed my point. I CAN'T USE TEXT MODE INSTALLATION AS I WANT TO 
INSTALL SOFTWARE RAID. (Sorry for shouting). Disk Druid in text mode gives no 
options for setting up RAID devices. Perhaps this might be a future enhancement?
Comment 3 Brent Fox 2001-10-01 11:51:16 EDT
Oh sorry.  We have added text mode support for setting up software raid in the
next version of Red Hat Linux, and in my haste I forgot that 7.1 didn't have
that capability.  My mistake.

Did you try booting with 'linux nofb'?
Comment 4 John Airey 2001-10-01 12:19:54 EDT
Yes thanks. I've tried linux nofb, linux vga=788, linux vga=773 and lowres. The 
latter is unusable. I'm glad to hear that RedHat 7.2 can install software raid 
in text mode, although it would have been good to know that before I ordered 
7.1!

I suggest we leave this one until I receive my copy of 7.1 (unless of course 
7.2 is imminent!)

This is the system specification for my machine: 
http://support.euro.dell.com/docs/dta/pesp53/00000001.htm

I have two more of these to install!
Comment 5 Brent Fox 2001-10-02 16:39:06 EDT
Well if you are interested, you can try out Roswell (the public beta for the
next release of Red Hat Linux) at  
ftp://ftp.redhat.com/pub/redhat/linux/beta/roswell/en/iso/i386/

I'd be interested to know if your problem is solved in Roswell.  I can't give
specific dates for the next release, but traditionally we do a release every six
months or so, and 7.1 was released in April, so I think you can put two and two
together.  :)

Having said that, I'm very surprised that you had problems with 7.1 on the
PowerEdge machines.  We have a test lab full of PowerEdge hardware that have all
been certified as compatible with Red Hat Linux.  I know for certain that the
ATI Mach64 1MB cards work.  It seems that the problems you are seeing are
related to the video card and the X Window server, but I can't imagine why it
isn't working.
Comment 6 John Airey 2001-10-05 04:13:59 EDT
Thanks for the suggestion. I'm already trying to download it, however at 01:15
this am (UTC) the roswell directory above had its file permissions changed so
that no-one can get into it. Can this be fixed please?

I've tried four times to download from ftp.mirror.ac.uk, two of these failed and
the other two give the same md5 checksum, but these do not match the MD5SUM
file. I'm trying again with an ftp client rather than a browser and I hope to
have more success.

Because of the imminent release of RedHat 7.2 we may well be exchanging 7.1.
That is likely to arrive today.
Comment 7 John Airey 2001-10-05 04:16:11 EDT
Thanks for the suggestion. I'm already trying to download it, however at 01:15
this am (UTC) the roswell directory above had its file permissions changed so
that no-one can get into it. Can this be fixed please?

I've tried four times to download from ftp.mirror.ac.uk, two of these failed and
the other two give the same md5 checksum, but these do not match the MD5SUM
file. I'm trying again with an ftp client rather than a browser and I hope to
have more success.

I have tried to install with a different CD-ROM drive and a different video
card, but I get the same result. 

Because of the imminent release of RedHat 7.2 we may well be exchanging 7.1.
That is likely to arrive today.
Comment 8 Brent Fox 2001-10-05 11:49:58 EDT
I can't explain why the IS team would remove read permissions to the Roswell
beta.  That doesn't make sense to me.  At any rate, it can be downloaded from
the University of North Carolina at: 
ftp://jungle.metalab.unc.edu/pub/Linux/distributions/redhat/beta/roswell/en/iso/i386/

They should have a pretty fast connection.  Let me know if that works out for you.
Comment 9 Brent Fox 2001-10-15 12:25:30 EDT
Any luck here?
Comment 10 John Airey 2001-10-16 04:34:51 EDT
Sorry to leave it so long. I couldn't download from this site as it was too 
slow for us here, so I burned the ISO images I obtained from ftp.mirror.ac.uk. 
The MD5SUM file at this site contains the following:

1b6a16dde304e2cc8b1d1d0285e5d58c  roswell-i386-disc1.iso
291ea51d5cf8b3a33b0bb7652c1f5fd8  roswell-i386-disc2.iso

But the packages I downloaded give this:

f8b7ca42d7df6d830ac91c66957da743  roswell-i386-disc1.iso
2b998cbdf760a4f01b34b6419020a01d  roswell-i386-disc2.iso

Burning the CD and running MD5sum gives another result altogether!

Roswell was successful at installing in graphical mode, however I still cannot 
get X-windows working with this card. The machine now has the evil NT4.0 
installed (on another SCSI disk) and the graphics card works fine. (I'm only 
installing it because I need to test the pathetic update system that MS has. 
It's not staying on, honest!)

I'm waiting for RH 7.2 to be released now. (The order for 7.1 was lost, so I'll 
be issuing a new order soon).
Comment 11 Brent Fox 2001-10-16 14:14:42 EDT
Hmm...I know that the ATI model of video card that you have should work.  We
have a lab full of PowerEdge machines that work fine with Seawolf as well as
Roswell.  The md5sum mismatches give me some concern that the cd's themselves
could be the source of some of the problems.

I'll leave this in NEEDINFO until you get a chance to try 7.2 Final.  I'd be
really surprised if the video card doesn't work correctly...
Comment 12 John Airey 2001-10-25 06:43:03 EDT
I've received my copy of RedHat 7.2 today, (and have downloaded the iso images 
correctly from ftp.mirror.ac.uk as well). However, it has already crashed on 
startup using standard and lowres options.

There might be some kind of hardware fault on this machine, although both 
RedHat 6.2 and NT4.0 (yuk!) install OK. I am getting an error probing the 
monitor, so it is even possible that the monitor or hardware are faulty.

My next two attempts will be to try again with a different monitor, and to try 
again with different hardware.
Comment 13 Brent Fox 2001-10-25 08:55:29 EDT
At this point, I'm hoping its hardware related.  I can't think of any reason why
it wouldn't work.  Like I said, the PowerEdge line was tested thoroughly.
Comment 14 John Airey 2001-10-25 09:09:29 EDT
Changing the monitor didn't help. I'm now installing on an older PowerEdge that 
only has dual P100 support, and apparently a Mach32 card (only .5MB ram). This 
hasn't caused any problems so far. I'm 99% certain that there is something in 
the probe of hardware that my particular card doesn't like. I have one other 
identical machine which I'll swap the motherboard out of later and see what 
happens.
Comment 15 John Airey 2001-10-25 12:04:08 EDT
I've just had the crash occur again when I put an adaptec 2910C card in my 
machine with the Mach-32 card. Is there some conflict between the mach-32/64 
code and the aic7xxx code?

I'll try again tomorrow on the original machine by removing the 2940 card and 
putting both disks on the built in SCSI controller. I bet it will work!
Comment 16 Brent Fox 2001-10-26 16:50:50 EDT
I don't know of any conflict between the two, except that they might both be
using the same IRQ, and that might cause a problem.  But the drivers are two
completely separate pieces of code, so I don't think they are conflicting.  If
the machine works without the 2940 card, then I would start suspecting that
something is fishy either with the card itself, or with the driver for that
card.  If it's a driver problem, then this bug report should be reassigned to
the kernel team, since they handle the kernel and the related drivers.

Any luck after removing the card?
Comment 17 John Airey 2001-10-30 09:49:11 EST
I've taken Occam's Razor to the machine, ie I removed everything except the CD-
Rom, floppy drive and one IDE hard disk. The on-board SCSI was disabled in the 
BIOS. I left the motherboard in ;-)

Now here comes the rub. RedHat 7.1 and 7.2 won't install graphically. Redhat 
7.1.94 (ie Roswell) does! I've played with the BIOS settings for the on-board 
VGA. 

Would the 7.1.94 boot disk be able to install 7.2, or am I asking too much?
Comment 18 Brent Fox 2001-10-30 22:47:28 EST
Hmm...it might work.  It probably has a slightly different kernel.  It may work;
it may not.  Give it a try....Keep a fire extinguisher handy  ;)
Comment 19 Brent Fox 2001-11-09 15:17:46 EST
Any more info here?
Comment 20 John Airey 2001-11-12 04:09:06 EST
Sorry about the delay. Fortunately my desk is by the fire extinguishers (and 
I've been trained in using them). Anyway, using the Roswell boot CD to install 
7.2 didn't work and the fire extinguishers are still in place.

For the machine in question I've decided that I'll install workstation without 
Gnome or KDE, since even a text-only install cannot run Xwindows at all. Until 
I decommission an identical machine at the end of the month (I hope) I can't be 
sure that this isn't a hardware issue. 

I'll keep you informed.
Comment 21 John Airey 2001-12-05 08:15:53 EST
So far I've been unable to try out the installer on another identical machine. I
hope to decommision this machine soon, so possibly next week I'll get onto it.
Comment 22 Brent Fox 2002-01-16 18:06:57 EST
Any progress here?
Comment 23 John Airey 2002-01-17 04:18:34 EST
Sorry for taking so long to get back to you. The second machine won't install 
in graphical mode either, and I doubt that the third one will either. I'll be 
moving onto that one soon.

The original problem, not being able to install software RAID has gone away now 
that the Enigma installer can manage that in text mode. However, there have 
been changes to the Enigma installer and/or XFree86 since Roswell came out. The 
latter is more likely as I cannot get XWindows to work on either machine. Since 
these are designated as servers this isn't a major problem.

It would be useful to have a copy of the changes to the installer and XFree86 
between Roswell and Enigma.
Comment 24 Brent Fox 2002-01-31 12:50:29 EST
The installer changes between Roswell and Enigma were mostly bugfixes, so there
was no major code changes.  I don't know about X...I suggest filing a bug
against the X component and maybe mharris@redhat.com can tell you more than I can.

Having said that, I'm stumped as to why the graphical installer won't work on
your machine.  Can you try booting the installer with 'nofb'?  This should avoid
framebuffer mode...perhaps that is causing the problem?
Comment 25 John Airey 2002-02-06 07:26:02 EST
I think you've lost your place. I've already tried nofb, and even tried it 
again with the latest boot disk image dated January 17th 2002. 

I have found a solution, but it's not ideal. I've brought in the Mach 64 card I 
had in my Escom machine at home (circa 1995) which is also 1MB, upgradeable to 
2MB. I've put a SCSI CD onto the Adaptec card, and the machine boots the CD 
into graphical mode fine. Reverting back to the onboard card doesn't work.

The inbuilt non-working card has P/N 113-25404-01, model 210888GX00 and 4x256K 
expansion slots. The card that works has P/N 113-32103-103, model 215CT222000 
and 2X512K expansion slots. 

Because this machine only has two PCI slots, I don't want to use a different 
graphics card, since I want to use one NIC and one extra SCSI card.

What now?
Comment 26 Brent Fox 2002-02-06 22:50:57 EST
I don't know why the onboard video card doesn't work with X.  This sounds now
like it is more of an X Windows problem than an installer problem, so I'm
changing the component of the bug report to X Windows.  Mike, do you know of any
problems with these older ATI mach64's?
Comment 27 Mike A. Harris 2002-03-12 15:10:49 EST
>Now here comes the rub. RedHat 7.1 and 7.2 won't install graphically. Redhat 
>7.1.94 (ie Roswell) does! I've played with the BIOS settings for the on-board 
>VGA. 

IMHO, that shows that this is not an XFree86 problem, as nothing significant
changed in XFree86 that would affect Mach64 cards in that timeframe.  I have
installed every release including all of our betas as they came out, on my
server, which has onboard Mach64 with the GUI installer and not seen any such
problems.

I'm closing the bug as there is no way for me to debug a problem like this
that I cannot reproduce, which isn't necessarily an XFree86 bug anyway.

If anyone at all, including the bug reporter can reproduce this, and
pinpoint it specifically to XFree86, and provide adequate details on
reproducing, then perhaps the problem can be looked into further.  There
are just too many variables, and too few details however to be able
to do anything.
and
Comment 28 John Airey 2002-09-15 18:14:44 EDT
OK, I solved this now (comes of being an RHCE I guess...)

In many cases anaconda cannot properly detect a video card. (I've even seen 
cases where Xconfigurator detects a video card incorrectly even when anaconda 
gets it right. eg my desktop machine has an Nvidia TNT card which Xconfigurator 
detects as a Mach 64 card, but I digress...)

What I do is install this in text mode, and skip the X configuration. Then I 
install the XFree86-compat-modules and XFree86-SVGA packages. 

Then I run Xconfigurator to set the display to 800x600 with 8 bit colour. That 
works, although I am getting less colour depth than is possible with 1MB. I 
can't remember the syntax of the command right now, but I'll put it here later.

This is a useful trick to get X-windows up on any card that gives problems at 
install time, eg a card that anaconda cannot detect during a kickstart install 
which then bails out of the install.

Note You need to log in before you can comment on or make changes to this bug.