This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 54157 - nss_ldap problems with multiple SSH (R) client windows
nss_ldap problems with multiple SSH (R) client windows
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-28 17:34 EDT by John Dalbec
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-28 17:34:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Dalbec 2001-09-28 17:34:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (Windows NT 5.0; U)

Description of problem:
My account is defined only to LDAP and not on the /etc files (recent change).  Also I recently upgraded tux, mkinitrd, filesystem, setup, 
e2fsprogs(-devel), and bash to Roswell because I'm looking for a kernel without long NFS write latencies (2.4.3) and without kupdated 
lockups on ReiserFS (2.4.7).  When I connect with the SSH(R) windows client, I'm OK as long as I have only one window open.  As soon 
as I try to open a second terminal window, I get disconnected.  If I run separate copies of the client, that's OK too.  If I alternate between 
terminal and file-transfer windows, I'm OK.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RH 7.1
2.Set up LDAP authorization
3.Sign on using SSH(R) Windows client as LDAP-only user
4.Open second terminal window
	

Actual Results:  Server disconnects.

Expected Results:  Second terminal window opens, executes new bash instance.

Additional info:

Sep 28 17:22:27 mail01 sshd[5283]: nss_ldap: could not get LDAP result - Can't contact LDAP server
Sep 28 17:22:27 mail01 sshd[5283]: nss_ldap: could not get LDAP result - Can't contact LDAP server
Sep 28 17:22:27 mail01 sshd[5283]: fatal: PAM session setup failed[14]: Cannot make/remove an entry for the specified session

The LDAP server is fine, or I wouldn't be able to log in in the first place.
Comment 1 John Dalbec 2001-10-02 10:21:15 EDT
D'oh! Upgrading nss_ldap to Roswell (requires upgrading db3 and openssl also) fixed the problem.

Note You need to log in before you can comment on or make changes to this bug.