Bug 54165 - /var/log/pacct not logrotated
/var/log/pacct not logrotated
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: psacct (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-29 11:17 EDT by josip
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-11 15:18:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description josip 2001-09-29 11:17:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; SunOS 5.7 sun4u)

Description of problem:
/etc/logrotate.d/psacct script is incorrect because the path to accton is
not correct and because /var/log/pacct is not recreated before the
postrotate step.  As a result, /var/log/pacct grows without bound
indefinitively.

I suggest fixing /etc/logrotate.d/psacct as follows:

# Logrotate file for psacct RPM
 
/var/log/pacct {
prerotate
        /sbin/accton
endscript
        notifempty
        monthly
        create 0664 root root
postrotate
        /sbin/accton /var/log/pacct
endscript
}     


Version-Release number of selected component (if applicable):
psacct-6.3.2-5

How reproducible:
Always

Steps to Reproduce:
1. accton /var/log/pacct
2. note unbounded growth in /var/log/pacct over time
3.
	

Additional info:

This problem is present on a clean complete Red Hat 7.1 install using
psacct-6.3.2-5
Comment 1 Mike A. Harris 2001-10-11 15:18:28 EDT
Looking into this...
Comment 2 Mike A. Harris 2002-03-12 05:04:22 EST
This has been fixed for a while now..
closing bug as fixed in -14 release.

Note You need to log in before you can comment on or make changes to this bug.