This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 54170 - for NeoMagic, sndconfig says: Can't open output file '/dev/dsp'
for NeoMagic, sndconfig says: Can't open output file '/dev/dsp'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-29 23:57 EDT by Bob Rintel
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 14:21:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bob Rintel 2001-09-29 23:57:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
I have an IBM Thinkpad 390 running RedHat 7.1 with all the errata-updates. 
When I run sndconfig, it correctly identifies the "NeoMagic 256 AV" but,
when it tries to play the sample, it says:

The following error occurred playing the sample:
sox: Can't open output file '/dev/dsp': No such device



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. sndconfig
2.
3.
	

Actual Results:  The following error occurred playing the sample:
sox: Can't open output file '/dev/dsp': No such device


Expected Results:  [the sound sample playing]

Additional info:

Every time the system boots, it displays the following message:
Note: /etc/modules.conf is more recent than
/lib/modules/2.4.3-1/modules.dep

What can I do to fix that?

Also, you gave Neomagic 256AV a 100% perfect score on your hardware
compatibility list.
Comment 1 Bob Rintel 2001-10-04 01:00:35 EDT
Here's more information:

Without the errata updates, RedHat 7.1's sndconfig says:
modprobe error
The following error occurred running the modprobe program:
/lib/modules/2.4.2-2/kernel/drivers/sound/nm256_audio.o:
init_module: No such device
/lib/modules/2.4.2-2/kernel/drivers/sound/nm256_audio.o: insmod
/lib/modules/2.4.2-2/kernel/drivers/sound/nm256_audio.o failed
/lib/modules/2.4.2-2/kernel/drivers/sound/nm256_audio.o: insmod
sound-slot-0 failed

And, with the new 2.4.3-12 kernel & the other errata/security updates, sndconfig
flashes this message:

NM256: This doesn't look to me like the AC97-compatible version.
       You can force the driver to load by passing in the module
       parameter:
              force_ac97 = 1
       More likely, you should be using the appropriate SB-16 or
       CS4232 driver instead.  (If your BIOS has settings for
       IRQ and/or DMA for the sound card, this is *not* the correct
       driver to use.)

and then it says:

The following error occurred playing the sample:
sox: Can't open output file '/dev/dsp': No such device.

From your hardware compatibility list, it should work.  Perhaps it worked in
previous RedHat versions (maybe 7.0).  Is there a workaround for this now?  Will
someone fix the driver?
Comment 2 Bob Rintel 2001-10-12 09:45:36 EDT
Combining suggestions from bugs #27509 and #28510, and then changing the numbers
to match my BIOS settings, I got it to work by having /etc/modules.conf contain:

alias sound-slot-0 opl3sa2
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&\
1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 \
|| :
options sound dmabuf=1
alias synth0 opl3
options opl3 io=0x388
options opl3sa2 mss_io=0x530 irq=5 dma=0 dma2=1 mpu_io=0x300 io=0x120 isapnp=0

Note that sndconfig doesn't let you choose IO=0x120 for the opl3sa2 card: it
insists on 370 or 380.  But setting it manually in modules.conf worked.

Note You need to log in before you can comment on or make changes to this bug.