Bug 54179 - fail to find even a 640x480 @ 60Hz GUI display for Roswell
fail to find even a 640x480 @ 60Hz GUI display for Roswell
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
roswell
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
http://www.griffintechnology.com/moni...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-30 15:35 EDT by baulv
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-30 20:56:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description baulv 2001-09-30 15:35:10 EDT
Description of Problem: XFree86 will not find a working config for Sony
CDP-1425 and Trident tgui9680


Version-Release number of selected component (if applicable):


How Reproducible: everytime X starts it farts and dies. Install GUI worked OK.


Steps to Reproduce:

1.  Install Roswell server OR workstation (with reformatting)
2.  pick a monitor(from "setup"), watch a beautitiful GUI appear, click OK
in the box
3.  restart "startx" , "X", or "XFree86" and the server crashes
4.  The GUI Monitor Test installer sometimes does not appear and gives up
after a couple of attemps.


Actual Results: a stinkin console


Expected Results: a perfect GUI

  
Additional Information:


Build Operating System: Linux 2.4.7-0.13.1smp i686 [ELF]
Build Host: stripples.devel.redhat.com

Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Sun Sep 30 13:52:14 2001
(==) Using config file: "/etc/X11/XF86Config-4"
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) ServerLayout "XFree86 Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "CustomConfiguration"
(**) |   |-->Device "Trident TGUI9660 (generic)"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) XKB: layout: "us"
(**) FontPath set to "unix/:7100"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7
II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 0.1.0
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 0.1.0
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(--) PCI:*(0:17:0) Trident TGUI 96xx rev 211, Mem @ 0xd5000000/22,
0xd5400000/16
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 1.0.0
I) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Module GLcore: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
(II) Module dri: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/linux/libdrm.a
(II) Module drm: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/drivers/linux/v4l_drv.o
II) Module v4l: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 0.0.1
(II) Loading /usr/X11R6/lib/modules/drivers/trident_drv.o
(II) Module trident: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 1.0.0
(II) v4l driver for Video4Linux
(II) TRIDENT: driver for Trident chipsets: tvga8900d, cyber9320, cyber9388,
        cyber9397, cyber9397dvd, cyber9520, cyber9525dvd, cyberblade/e4,
        tgui9420dgi, tgui9440agi, tgui9660, tgui9680, providia9682,
        providia9685, cyber9382, cyber9385, 3dimage975, 3dimage985, blade3d,
        cyberbladei7, cyberbladei7d, cyberbladei1, cyberbladei1d,
        cyberbladeAi1, cyberbladeAi1d, cyberbladeXP, cyberbladeXPm
(--) Assigning device section with no busID to primary device
(--) Chipset tgui9660 found
(**) TRIDENT(0): Depth 16, (--) framebuffer bpp 16
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 0.1.0
(II) Loading /usr/X11R6/lib/modules/libramdac.a
(II) Module ramdac: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 0.1.0
(==) TRIDENT(0): RGB weight 565
(==) TRIDENT(0): Default visual is TrueColor
(==) TRIDENT(0): Using gamma correction (1.0, 1.0, 1.0)
(==) TRIDENT(0): Linear framebuffer at 0xD5000000
(--) TRIDENT(0): IO registers at 0xD5400000
(II) Loading /usr/X11R6/lib/modules/libvbe.a
(II) Module vbe: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/linux/libint10.a
(II) Module int10: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 1.0.0
(II) TRIDENT(0): initializing int10
(II) TRIDENT(0): Primary V_BIOS segment is: 0xc000
(II) TRIDENT(0): VESA BIOS detected
(--) TRIDENT(0): Revision is 1
(==) TRIDENT(0): Using HW cursor
(--) TRIDENT(0): Found TGUI9680 chip
(--) TRIDENT(0): RAM type is Standard DRAM
(--) TRIDENT(0): VideoRAM: 2048 kByte
(--) TRIDENT(0): Memory Clock is 31.82 MHz
(==) TRIDENT(0): Min pixel clock is 12 MHz
(--) TRIDENT(0): Max pixel clock is 135 MHz
(II) TRIDENT(0): CustomConfiguration: Using hsync range of 46.00-51.00 kHz
(II) TRIDENT(0): CustomConfiguration: Using vrefresh range of 50.00-90.00 Hz
(II) TRIDENT(0): Clock range:  12.00 to 135.00 MHz
(II) TRIDENT(0): Not using default mode "640x350" (hsync out of range)
(II) TRIDENT(0): Not using default mode "640x400" (hsync out of range)
(II) TRIDENT(0): Not using default mode "720x400" (hsync out of range)
(II) TRIDENT(0): Not using default mode "640x480" (hsync out of range)
(II) TRIDENT(0): Not using default mode "640x480" (hsync out of range)
(II) TRIDENT(0): Not using default mode "640x480" (hsync out of range)
(II) TRIDENT(0): Not using default mode "640x480" (hsync out of range)
(II) TRIDENT(0): Not using default mode "800x600" (hsync out of range)
(II) TRIDENT(0): Not using default mode "800x600" (hsync out of range)
(II) TRIDENT(0): Not using default mode "800x600" (hsync out of range)
(II) TRIDENT(0): Not using default mode "1024x768" (hsync out of range)
(II) TRIDENT(0): Not using default mode "1024x768" (hsync out of range)
(II) TRIDENT(0): Not using default mode "1024x768" (hsync out of range)
(II) TRIDENT(0): Not using default mode "1024x768" (hsync out of range)
(II) TRIDENT(0): Not using default mode "1152x864" (hsync out of range)
(II) TRIDENT(0): Not using default mode "1280x960" (insufficient memory for
mode)
(II) TRIDENT(0): Not using default mode "1280x960" (insufficient memory for
mode)
(II) TRIDENT(0): Not using default mode "1280x1024" (insufficient memory
for mode)
(II) TRIDENT(0): Not using default mode "1280x1024" (insufficient memory
for mode)
(II) TRIDENT(0): Not using default mode "1280x1024" (insufficient memory
for mode)
(II) TRIDENT(0): Not using default mode "1600x1200" (insufficient memory
for mode)
(II) TRIDENT(0): Not using default mode "1600x1200" (insufficient memory
for mode)
(II) TRIDENT(0): Not using default mode "1600x1200" (insufficient memory
for mode)
(II) TRIDENT(0): Not using default mode "1600x1200" (insufficient memory
for mode)
(II) TRIDENT(0): Not using default mode "1600x1200" (insufficient memory
for mode)
(II) TRIDENT(0): Not using default mode "1792x1344" (insufficient memory
for mode)
(II) TRIDENT(0): Not using default mode "1792x1344" (insufficient memory
for mode)
(II) TRIDENT(0): Not using default mode "1856x1392" (insufficient memory
for mode)
(II) TRIDENT(0): Not using default mode "1856x1392" (insufficient memory
for mode)
(II) TRIDENT(0): Not using default mode "1920x1440" (insufficient memory
for mode)
(II) TRIDENT(0): Not using default mode "1920x1440" (insufficient memory
for mode)
(II) TRIDENT(0): Not using default mode "1400x1050" (insufficient memory
for mode)
(II) TRIDENT(0): Not using default mode "1400x1050" (insufficient memory
for mode)
(--) TRIDENT(0): Virtual size is 800x600 (pitch 1024)
**) TRIDENT(0): Default mode "800x600": 49.5 MHz, 46.9 kHz, 75.0 Hz
(==) TRIDENT(0): DPI set to (75, 75)
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/libi2c.a
(II) Module i2c: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 1.2.0
(II) Loading /usr/X11R6/lib/modules/libxaa.a
(II) Module xaa: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
        compiled for 4.1.0.1, module version = 1.0.0
(==) TRIDENT(0): Write-combining range (0xd5000000,0x200000)
(II) TRIDENT(0): Initializing int10
(II) TRIDENT(0): Primary V_BIOS segment is: 0xc000
(II) TRIDENT(0): Using XFree86 Acceleration Architecture (XAA)
        Screen to screen bit blits
        Solid filled rectangles
        8x8 mono pattern filled rectangles
        Indirect CPU to Screen color expansion
        Solid Lines
        Dashed Lines
        Offscreen Pixmaps
        Setting up tile and stipple cache:
                22 128x128 slots
                32 8x8 color expansion slots
(==) TRIDENT(0): Backing store disabled
(==) TRIDENT(0): Silken mouse enabled
(**) TRIDENT(0): DPMS enabled
(**) Mouse0: Protocol: "PS/2"
(**) Mouse0: Core Pointer
(==) Mouse0: Buttons: 3
(**) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(II) Keyboard "Keyboard0" handled by legacy driver
(II) XINPUT: Adding extended input device "Mouse0"  (type: MOUSE)
[root@localhost X11R6]#

[root@localhost X11R6]# X

XFree86 Version 3.3.6a / X Window System
(protocol Version 11, revision 0, vendor release 6300)
Release Date: April 19, 2001
        If the server is older than 6-12 months, or if your card is newer
        than the above date, look for a newer version before reporting
        problems.  (see http://www.XFree86.Org/FAQ)
Operating System: Linux 2.4.7-0.13.1smp i686 [ELF]
Configured drivers:
  SVGA: server for SVGA graphics adaptors (Patchlevel 1):
      s3_savage, NV1, STG2000, RIVA 128, RIVA TNT, RIVA TNT2,
      RIVA ULTRA TNT2, RIVA VANTA, RIVA ULTRA VANTA, RIVA INTEGRATED,
      GeForce 256, GeForce DDR, Quadro, GeForce2 GTS, GeForce2 GTS (rev1),
      GeForce2 Ultra, Quadro 2 Pro, GeForce2 MX, GeForce2 MX DDR,
      Quadro 2 MXR, ET4000, ET4000W32, ET4000W32i, ET4000W32i_rev_b,
      ET4000W32i_rev_c, ET4000W32p, ET4000W32p_rev_a, ET4000W32p_rev_b,
      ET4000W32p_rev_c, ET4000W32p_rev_d, ET6000, ET6100, et3000, pvga1,
      wd90c00, wd90c10, wd90c30, wd90c24, wd90c31, wd90c33, gvga, r128, ati,
      sis86c201, sis86c202, sis86c205, sis86c215, sis86c225, sis5597,
      sis5598, sis6326, sis530, sis620, sis300, sis630, sis540, tvga8200lx,
      tvga8800cs, tvga8900b, tvga8900c, tvga8900cl, tvga8900d, tvga9000,
      tvga9000i, tvga9100b, tvga9200cxr, tgui9400cxi, tgui9420, tgui9420dgi,
      tgui9430dgi, tgui9440agi, cyber9320, tgui9660, tgui9680, tgui9682,
      tgui9685, cyber9382, cyber9385, cyber9388, cyber9397, cyber9520,
      cyber9525, 3dimage975, 3dimage985, cyber9397dvd, blade3d, cyberblade,
      clgd5420, clgd5422, clgd5424, clgd5426, clgd5428, clgd5429, clgd5430,
      clgd5434, clgd5436, clgd5446, clgd5480, clgd5462, clgd5464, clgd5465,
      clgd6205, clgd6215, clgd6225, clgd6235, clgd7541, clgd7542, clgd7543,
      clgd7548, clgd7555, clgd7556, ncr77c22, ncr77c22e, cpq_avga, mga2064w,
      mga1064sg, mga2164w, mga2164w AGP, mgag200, mgag100, mgag400, oti067,
     oti077, oti087, oti037c, al2101, ali2228, ali2301, ali2302, ali2308,
      ali2401, cl6410, cl6412, cl6420, cl6440, video7, ark1000vl, ark1000pv,
      ark2000pv, ark2000mt, mx, realtek, s3_virge, AP6422, AT24, AT3D,
      s3_svga, NM2070, NM2090, NM2093, NM2097, NM2160, NM2200, ct65520,
 ct65525, ct65530, ct65535, ct65540, ct65545, ct65546, ct65548,
      ct65550, ct65554, ct65555, ct68554, ct69000, ct64200, ct64300,
      mediagx, V1000, V2100, V2200, p9100, spc8110, i740, i740_pci,
      Voodoo Banshee, Voodoo3, i810, i810-dc100, i810e, i815, smi, generic
(using VT number 7)

XF86Config: /usr/X11R6/lib/X11/XF86Config
(**) stands for supplied, (--) stands for probed/default values
(**) XKB: keycodes: "xfree86"
(**) XKB: types: "default"
(**) XKB: compat: "default"
(**) XKB: symbols: "us(pc101)"
(**) XKB: geometry: "pc"
(**) XKB: rules: "xfree86"
(**) XKB: model: "pc101"
(**) XKB: layout: "us"
(**) Mouse: type: PS/2, device: /dev/mouse, buttons: 3
(**) Mouse: 3 button emulation (timeout: 50ms)
(**) SVGA: Graphics device ID: "Trident TGUI9660 (generic)"
(**) SVGA: Monitor ID: "CustomConfiguration"
--) SVGA: Mode "640x480" needs hsync freq of 36.46 kHz. Deleted.
(--) SVGA: Mode "1024x768" needs hsync freq of 56.48 kHz. Deleted.
(**) FontPath set to "unix/:7100"
(--) SVGA: PCI: Trident TGUI 96xx rev 211, Memory @ 0xd5000000, 0xd5400000
(--) Trident chipset version: 0xd3 (TGUI96xx)
(--) SVGA: BIOS reports Clock Control Bits 0x0
(--) SVGA: Detected a Trident 9680.
(--) SVGA: Revision 1.
(--) SVGA: Using Trident programmable clocks
(--) SVGA: chipset:  tgui9680
(--) SVGA: videoram: 2048k
(**) SVGA: Using 16 bpp, Depth 16, Color weight: 565
(--) SVGA: Maximum allowed dot-clock: 135.000 MHz
(**) SVGA: Mode "800x600": mode clock =  50.000
(--) SVGA: Virtual resolution set to 800x600
(--) SVGA: SpeedUp code selection modified because virtualX != 1024
(--) SVGA: Using Linear Frame Buffer at 0x0d5000000, Size 2MB
 
Fatal server error:
could not open default font 'fixed'
 
When reporting a problem related to a server crash, please send
the full server output, not just the last messages
 
[root@localhost X11R6]#

[root@localhost root]# SuperProbe
 
SuperProbe Version 2.23 (2000 November 28)
        (c) Copyright 1993,1994 by David Wexelblat <dwex@xfree86.org>
        (c) Copyright 1994-1998 by The XFree86 Project, Inc
 
        This work is derived from the 'vgadoc2.zip' and
        'vgadoc3.zip' documentation packages produced by Finn
        Thoegersen, and released with all appropriate permissions
        having been obtained.  Additional information obtained from
        'Programmer's Guide to the EGA and VGA, 2nd ed', by Richard
        Ferraro, and from manufacturer's data books
 
Bug reports are welcome, and should be sent to XFree86@XFree86.org.
In particular, reports of chipsets that this program fails to
correctly detect are appreciated.
 
Before submitting a report, please make sure that you have the
latest version of SuperProbe (see http://www.xfree86.org/FAQ).
 
WARNING - THIS SOFTWARE COULD HANG YOUR MACHINE.
          READ THE SuperProbe.1 MANUAL PAGE BEFORE
          RUNNING THIS PROGRAM.
 
          INTERRUPT WITHIN FIVE SECONDS TO ABORT!
 
 
First video: Super-VGA
        Chipset: Trident GUI 9680 (PCI Probed)
        Memory:  2048 Kbytes
        RAMDAC:  Trident Built-In 15/16/24-bit DAC
                 (with 6-bit wide lookup tables (or in 6-bit mode))
[root@localhost root]#



http://www.griffintechnology.com/monitors/Sony07.html
Comment 1 baulv 2001-09-30 15:47:14 EDT
the usual /var/log/XFree86.0.log   is not to be found in Roswell. The Aliens got
it ?

Comment 2 baulv 2001-09-30 20:56:16 EDT
The problem vanished after all XFree86 modules had been "up2date'd".

Comment 3 Mike A. Harris 2001-10-01 08:17:50 EDT
Looks like you got it going ok.

Note You need to log in before you can comment on or make changes to this bug.