Bug 54180 - Errors installing DocBook DTDs
Summary: Errors installing DocBook DTDs
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: sgml-common   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-30 23:42 UTC by Stephen Rasku
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-01 17:41:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen Rasku 2001-09-30 23:42:07 UTC
Description of Problem:

I got a number of errors when trying to install the docbook DTDs:

[root@kiev rpms]# ls
docbook-dtd412-xml-1.0-1.noarch.rpm   docbook-dtd41-xml-1.0-7.noarch.rpm
docbook-dtd41-sgml-1.0-10.noarch.rpm
[root@kiev rpms]# rpm -ivh *.rpm
Preparing...                ###########################################
[100%]
   1:docbook-dtd412-xml     ########################################### [
33%]
install-catalog: unable to write in /etc/sgml.
install-catalog: unable to write in /etc/sgml.
install-catalog: unable to write in /etc/sgml.
install-catalog: unable to write in /etc/sgml.
ln: creating symbolic link `/etc/sgml/xml-docbook.cat' to
`/etc/sgml/xml-docbook-4.1.2.cat': No such file or directory
error: execution of %post scriptlet from docbook-dtd412-xml-1.0-1 failed,
exit status 1
   2:docbook-dtd41-sgml     ########################################### [
66%]
install-catalog: unable to write in /etc/sgml.
install-catalog: unable to write in /etc/sgml.
install-catalog: unable to write in /etc/sgml.
install-catalog: unable to write in /etc/sgml.
ln: creating symbolic link `/etc/sgml/sgml-docbook.cat' to
`/etc/sgml/sgml-docbook-4.1.cat': No such file or directory
error: execution of %post scriptlet from docbook-dtd41-sgml-1.0-10 failed,
exit status 1
   3:docbook-dtd41-xml      ###########################################
[100%]
install-catalog: unable to write in /etc/sgml.
install-catalog: unable to write in /etc/sgml.
install-catalog: unable to write in /etc/sgml.
install-catalog: unable to write in /etc/sgml.
ln: creating symbolic link `/etc/sgml/xml-docbook.cat' to
`/etc/sgml/xml-docbook-4.1.cat': No such file or directory
error: execution of %post scriptlet from docbook-dtd41-xml-1.0-7 failed,
exit status 1

It appears that it is trying to write into /etc/sgml on which doesn't exist
on my system.

Version-Release number of selected component (if applicable):
	docbook-dtd412-xml-1.0-1
	docbook-dtd41-sgml-1.0-10
	docbook-dtd41-xml-1.0-7

Actual results:

	According to "rpm -qa | grep dtd" these packages were installed on the
system.

Expected Results:

The packages should either install cleanly or not at all.

Comment 1 Tim Waugh 2001-10-01 09:26:28 UTC
What does 'rpm -V sgml-common' say?



Comment 2 Stephen Rasku 2001-10-01 15:52:38 UTC
[stephen@kiev users/stephen] 501 $ rpm -V sgml-common
missing    /etc/sgml/sgml.conf


Comment 3 Tim Waugh 2001-10-01 17:26:05 UTC
Looks like a duplicate of bug #47485, perhaps.


Comment 4 Tim Waugh 2001-10-05 09:56:00 UTC
sgml-common-0.6.3-1 now owns /etc/sgml, which should fix this problem.



Note You need to log in before you can comment on or make changes to this bug.