Bug 54187 - Permissions on login
Permissions on login
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: dev (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-01 07:57 EDT by Gabriel Schulhof
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 11:54:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gabriel Schulhof 2001-10-01 07:57:03 EDT
Description of Problem:
Permissions, when logging in through gdm, don't work.

Version-Release number of selected component (if applicable):
dev-3.1.0-14

How Reproducible:
Every time

Steps to Reproduce:
1. Create two different user accounts
2. Log in using gdm with one
3. Observe the soundcard work (/dev/dsp has proper ownership 
  (user1.root))
4. Log in using gdm with the other
5. Sound card doesn't work because /dev/dsp still has ownership
   user1.root, instead of user2.root

Actual Results:
I'm not certain which component is responsible for automagically
changing the ownership of some /dev files to the user currently
logging in via gdm, however, once the first user logs in and then
logs out, another user that logs in will find that the ownership
on those same files has not been automagically changed to hers
(the second user's).

Expected Results:
One would expect that ownership of files such as /dev/dsp would
switch to the user currently logged in, so that whoever sits in
front of the computer may use the sound card.  Why can the first
user who logs in use the sound card, but no subsequent user ?

Additional Information:
This is a real inconvenience, because I have to log in as root
and manually adjust these permissions for each user logged in
locally via gdm.  BTW:  I've seen this bug ever since 6.2 .
Comment 1 ronnie 2002-07-03 09:56:33 EDT
I experience this problem with rh7.3 (dev-3.3-4) logging 
in from kdm.
Comment 2 Bill Nottingham 2006-08-07 14:26:14 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 3 Bill Nottingham 2006-10-18 11:54:40 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.