Bug 54196 - Davicom ethernet identified as Tulip
Davicom ethernet identified as Tulip
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-01 10:15 EDT by Ecmel Ercan
Modified: 2013-07-02 22:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 07:53:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci (730 bytes, text/plain)
2001-10-01 10:58 EDT, Ecmel Ercan
no flags Details

  None (edit)
Description Ecmel Ercan 2001-10-01 10:15:46 EDT
Description of Problem:
My davicom (dmfe.o) ethernet card identified as (tulip.o).
Comment 1 Bill Nottingham 2001-10-01 10:54:49 EDT
lspci output?
Comment 2 Ecmel Ercan 2001-10-01 10:58:42 EDT
Created attachment 33080 [details]
lspci
Comment 3 Bill Nottingham 2001-10-01 11:02:26 EDT
The tulip driver lists that PCI id as supported by the tulip driver, so that's
what we use. Does that not work for you?
Comment 4 Ecmel Ercan 2001-10-01 11:18:47 EDT
It works, but after sometime (randomly) it stops working at all.  I have to
hard-reset the machine to get it working again.
Comment 5 Bill Nottingham 2001-10-01 11:45:48 EDT
That would be a driver bug; assigning to the kernel.
Comment 6 Arjan van de Ven 2001-10-01 12:10:19 EDT
And dmfe does work ?
Comment 7 Ecmel Ercan 2001-10-02 03:48:08 EDT
dmfe works perfect for the last 9 months and working now in Roswell beta.
Comment 8 Richard Lloyd 2001-11-07 12:08:14 EST
The Dell Dimension 4300 (heavily advertised on UK TV) comes with
a Davicom DM9102 NIC when purchased in the UK as part of the
bundle (funnily, the NIC section of dell.co.uk only lists 3com
cards, but you get Davicom if you ask for the NIC to be bundled).

When I went through the 7.2 installer, it recognised it as
tulip and I duly got the symptoms the original poster described
("ifconfig eth0" reported many receive errors, the network card
would either not init at all on bootup, init at 1 *second* pings
to another local machine or init with plenty of receive errors).

I changed /etc/modules.conf to use dmfe instead of tulip and it
worked perfectly with no errors.

I would urge a rapid fix of this because Dell PCs are hit very,
very badly by this, at least in the UK.

Tip - there's a nice Tulip diag tool in the tulip 1.1.8 package
at http://sourceforge.net/projects/tulip/ - this was the only
"easy" way to actually find out what card I had without opening
the case up (yet again :-) ).
Comment 9 Jeff Solomon 2002-01-22 18:41:33 EST
Just a note that this applies to Dell 8200's as well. We've bought them both in
October and this month and both boxes had the same NIC as the 4300 that
rkl@connect.org.uk describes.

A knowlegde base article should really be created that would match on "Dell 4300
8200 Davicom" that would explain the fix to this problem.

In case you're wondering: Edit /etc/modules.conf. Replace the word "tulip" with
"dmfe" and reboot.
Comment 10 Need Real Name 2002-03-04 19:50:59 EST
SmartStep 100D bundle from Dell includes this NIC as well.
In a default 7.2 install, the NIC will ultimately fail.  Message logs will 
report this during boot up...

Feb 13 14:27:13 mailhub kernel: Linux Tulip driver version 0.9.15-pre6 (July 
2, 2001)
Feb 13 14:27:13 mailhub kernel: PCI: Found IRQ 11 for device 01:0a.0
Feb 13 14:27:13 mailhub kernel: tulip0:  EEPROM default media type Autosense.
Feb 13 14:27:13 mailhub kernel: tulip0:  Index #0 - Media MII (#11) described 
by a 21140 MII PHY (1) block.
Feb 13 14:27:13 mailhub kernel: tulip0:  Index #1 - Media 10baseT (#0) 
described by a 21140 non-MII (0) block.
Feb 13 14:27:13 mailhub kernel: tulip0:  Index #2 - Media 100baseTx (#3) 
described by a 21140 non-MII (0) block.
Feb 13 14:27:13 mailhub kernel: tulip0:  Index #3 - Media 10baseT-FDX (#4) 
described by a 21140 non-MII (0) block.
Feb 13 14:27:13 mailhub kernel: tulip0:  Index #4 - Media 100baseTx-FDX (#5) 
described by a 21140 non-MII (0) block.
Feb 13 14:27:13 mailhub kernel: tulip0:  MII transceiver #1 config 3100 status 
7809 advertising 01e1.
Feb 13 14:27:13 mailhub kernel: eth0: Davicom DM9102/DM9102A rev 49 at 
0xc8882000, 00:80:AD:7B:0A:98, IRQ 11.

And eventually fail with...

Feb 27 10:20:17 mailhub kernel: NETDEV WATCHDOG: eth0: transmit timed out
Feb 27 10:20:17 mailhub kernel: eth0: 21140 transmit timed out, status 
fc540000, SIA ffffff49 00000000 00000000 00000000, resetting...
Feb 27 10:20:17 mailhub kernel: eth0: transmit timed out, switching to 
100baseTx-FDX media.
Feb 27 10:20:25 mailhub kernel: NETDEV WATCHDOG: eth0: transmit timed out
Feb 27 10:20:25 mailhub kernel: eth0: 21140 transmit timed out, status 
fc540000, SIA ffffff49 00000000 00000000 00000000, resetting...
Feb 27 10:20:25 mailhub kernel: eth0: transmit timed out, switching to 
100baseTx-FDX media.
Feb 27 10:20:33 mailhub kernel: NETDEV WATCHDOG: eth0: transmit timed out
Feb 27 10:20:33 mailhub kernel: eth0: 21140 transmit timed out, status 
fc540000, SIA ffffff49 00000000 00000000 00000000, resetting...
Feb 27 10:20:33 mailhub kernel: eth0: transmit timed out, switching to MII 
media.
Feb 27 10:20:35 mailhub kernel: eth0: Setting half-duplex based on MII#1 link 
partner capability of 0021.
Feb 27 10:20:41 mailhub kernel: NETDEV WATCHDOG: eth0: transmit timed out


Comment 11 Jeff Garzik 2003-01-31 11:28:32 EST
Does this still occur, when the latest kernel errata rpm is installed?
Comment 12 Alan Cox 2003-06-05 07:53:35 EDT
No response in several months.
Closing as it seems to be fixed

Note You need to log in before you can comment on or make changes to this bug.