Bug 54197 - Legacy Applications capplet is missing from Gnome Control Center
Legacy Applications capplet is missing from Gnome Control Center
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: control-center (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Mason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-01 10:57 EDT by Ecmel Ercan
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-01 10:57:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (41.32 KB, image/jpeg)
2001-10-02 10:21 EDT, Ecmel Ercan
no flags Details

  None (edit)
Description Ecmel Ercan 2001-10-01 10:57:28 EDT
Description of Problem:
Legacy Applications capplet is missing from Gnome Control Center

This is a very handy capplet especially if you use Qt programs under Gnome.
Though it did not work very well in previous versions, I hope RedHat will
include a working one in the final release.
Comment 1 David Mason 2001-10-01 11:16:36 EDT
this is a capplet provided by Ximian (or others) we have never provided it. This
is based on software that changes the look and feel of many different widget
sets which we do not want to do as most users do not need the extra options.
Thanks for the input.
Comment 2 Ecmel Ercan 2001-10-01 11:22:24 EDT
But without this capplet, Qt uses a very big font.  (Try using Kylix under Gnome)

Then how can I change the font of Qt under gnome?  I don't have KDE at all.
Comment 3 David Mason 2001-10-01 11:28:25 EDT
Kylix does not use QT it uses its own widget set - you will need to ask Borland
- we do not use (or even have) it here. Kylix attempts to match QT and GTK+ -
there is probably some dot file it stores somewhere in your home dir - but that
is a guess.
Comment 4 Ecmel Ercan 2001-10-02 03:48:52 EDT
Then try using Kylix compiled programs, or Eagle layout editor or any other Qt
program.
Comment 5 David Mason 2001-10-02 10:03:06 EDT
I use QT apps all the time in GNOME and they look just fine. Again, Kylix and
apps created with Kylix do not use QT or GTK+ they use a Kylix-specific widget
set because Borland could not choose between the two.
Comment 6 Ecmel Ercan 2001-10-02 10:19:35 EDT
This is wrong.  Kylix compiled applications uses Qt and depends on it.  Please
refer to borland.com

On my RedHat Roswell and previous versions, applications using Qt under gnome
displays big fonts.  With legacy applications capplet, they use what ever GTK+
theme uses. This makes my desktop unified and makes Qt apps more usable under Gnome.
Comment 7 Ecmel Ercan 2001-10-02 10:21:43 EDT
Created attachment 33218 [details]
Screenshot
Comment 8 David Mason 2001-10-02 10:30:01 EDT
Sorry - that is not QT in your screenshot - if anything it looks like GTK+.  I
am also sorry, I do not know of any way to change the fonts in a QT-only app - I
also know very very few apps that are QT without KDE - we dont ship any that I
am aware of. If it relies on any of the KDE libraries it is rather easy to do in
their control center or in a dot file. We have never shipped any tool that would
alter the look of QT-only apps. I do not know where you got the control-center
capplet you did - but if you find it I assume you can use it here.  Please try
contacting the maker of that Eagle application (we also have never shipped that
application) - they can probably tell you.
Comment 9 Ecmel Ercan 2001-10-07 09:29:47 EDT
This is a Qt application.  

Qt default theme resembles Gtk.  Anyway thanks a lot for your time.



Note You need to log in before you can comment on or make changes to this bug.