This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 542358 - SystemSettings printer module is not working when KDE language is set to polish
SystemSettings printer module is not working when KDE language is set to polish
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-29 08:18 EST by Stan Trzmiel
Modified: 2010-10-01 16:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-01 16:43:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stan Trzmiel 2009-11-29 08:18:12 EST
Description of problem:
  KCM Printer (SystemSetting printer applet) doesn't work when language is set to "polish"
  At attempt to open printer configuration results with SystemSettings displaying a message:

  "Printer Configuration" service doesn't offer 'KCModule' interface with 'system-config-printer-kde/system-config-printer-kde.py' keyword. This infrastructure dos not allow creating components of given type.

  (my more or less rough translation from polish).

   System-config-printer-kde (separate app) is installed and works ok, also setting language to lets say english also makes KCM Printer to work.


Version-Release number of selected component (if applicable):
   Problem occured just when KCM Printer was introduced (KDE 4.2 iirc?) and is present up to KDE 4.4 alpha (3.75)

My current packages are:
   kdebase-4.3.3-3.fc12.i686
   kdeutils-printer-applet-4.3.3-1.fc12.i686
   kdeutils-4.3.3-1.fc12.i686
   system-config-printer-kde-4.3.3-1.fc12.i686

How reproducible: everytime.


Steps to Reproduce:
1. Set language to polish
2. logout/login to apply the changes
3. open systemsettings and attempt to cunfigure printer via applet
  
Actual results:
Printer config applet is not visible and error message quoted above can be read.

Expected results:
Printer configuration applet opens up so user can set up the device

Additional info:
Comment 1 Rex Dieter 2009-12-02 16:23:50 EST
rpm -q sip PyQt4 PyKDE4
please.

Tested here (admittedly, English locale), using
$ rpm -q sip PyQt4 PyKDE4
sip-4.9.3-1.fc12.x86_64
PyQt4-4.6.2-5.fc12.x86_64
PyKDE4-4.3.3-4.fc12.x86_64
Comment 2 Rex Dieter 2009-12-02 16:42:51 EST
nvm, after installing kde-l10n-Polish, and switching language, I'm seeing a failure too.

Time to upstream to bugs.kde.org, mind doing so?
Comment 3 Stan Trzmiel 2009-12-02 17:05:45 EST
OK I'll do, 'tho I've tried with Kubuntu livecd and it worked fine. Maybe due incomplete Kubuntu translation or something.
Comment 4 Stan Trzmiel 2009-12-02 18:10:39 EST
Ok, bug filled upstream,  bug no: 217137. Here's the linky:
https://bugs.kde.org/show_bug.cgi?id=217137
Comment 5 Kevin Kofler 2009-12-02 19:55:07 EST
Kubuntu does their own thing with respect to translations.
Comment 6 Stan Trzmiel 2010-10-01 16:43:18 EDT
Solved upstream

Note You need to log in before you can comment on or make changes to this bug.