Bug 54275 - xscreensaver 3.29, 05-Feb-2001 'Blaster' demo locks up computer
xscreensaver 3.29, 05-Feb-2001 'Blaster' demo locks up computer
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-02 17:58 EDT by Mark Harig
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-04 08:17:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Harig 2001-10-02 17:58:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
When I run the 'Blaster'  demo,  the screen saver starts briefly and then
my computer is locked from any input.   I am unable to recover control that
should normally be returned by pressing the <Enter> key or the <Esc> key. 
Even <Ctrl-Alt-Del> is not recognized and I am forced to press my
computer's "Reset" button to reboot.  I have reproduced this problem
several times with the same result.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. After booting RH Linux 7.1 (kernel 2.4.3-12), log onto a user account. 
I am running the Gnome
    graphical interface.
2. Right-click on the 'Lock' icon from the Panel, and select 'Preferences'
from the menu.
3. When the XscreenSaver application is displayed, scroll through the list
of Graphics Demos to find the 'Blaster' demo.  It is listed between 'C
Curve' and 'Bumps'.
4. Select (highlight) the 'Blaster' item in the list using your mouse, then
click the Demo button to begin a demonstration of the screensaver.


	

Actual Results:  A few seconds after starting to display the 'Blaster'
screensaver, the screen freezes and no additional keyboard input is
accepted.

Expected Results:  Instead, when I press the <Enter> or <Esc> key, the
screensaver should stop running and the screen's display prior to running
the screensaver should be restored.

Additional info:
Comment 1 Bill Nottingham 2001-10-02 23:13:21 EDT
xscreensaver really shouldn't lock the system, especially with a 2D screensaver.
This usually indicates an X driver bug, or possibly a kernel bug. Assigning to
XFree86 for now.
Comment 2 Mike A. Harris 2001-10-04 08:17:17 EDT
After you experience a crash, please attach both your X server log, and
your config file to the bug report.  USe the link below.

Thanks
Comment 3 Mike A. Harris 2002-02-09 10:44:49 EST
Bug presumed to be fixed now with current release due to lack of
feedback, closing.

If problem persists, reopen report with attached information requested above.

Note You need to log in before you can comment on or make changes to this bug.