Bug 54276 - Install routine stops: received signal 4 seems to be when probing for USB mouse
Install routine stops: received signal 4 seems to be when probing for USB mouse
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-02 18:00 EDT by Michael Timony
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-04 10:41:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Timony 2001-10-02 18:00:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en]C-CCK-MCD FC-02  (WinNT; U)

Description of problem:
Install/upgrading a Compaq 6500 Proliant server with Redhat 7.1. The install routine stops when it appears to probe for a USB mouse. 
The system has no USB. Messages to the console are as follows:

Virtual Console 1 (Ctrl-ALt-F1):
Running anaconda please wait ...
install exited abnormally -- received signal 4
sending termination signals ... done
disabling swap ...
unmounting filesystems

The last 2 lines from Virtual Console 3 (Ctrl-Alt-F3):
*going to insmod ext3.0 (path is NULL)
*looking for USB mouse ...

The last 2 lines from Virtual Console 4 (Ctrl-Alt-F4):
<4>raid 5: using function: p5_mmx (1179.200 MB/sec)
<6>raid5 personality registered as nr4

Additionally, the system currently has Redhat 7.0 installed, system info, if needed, is as follows:

Devices:
Character devices:
  1 mem
  2 pty
  3 ttyp
  4 ttyS
  5 cua
  7 vcs
 10 misc
 29 fb
 36 netlink
128 ptm
136 pts
162 raw

Block devices:
  1 ramdisk
  2 fd
  3 ide0
  9 md
 72 ida0
 73 ida1

 dma:
 4: cascade

interrupts:
         CPU0       CPU1       CPU2       CPU3
  0:      81783      69532      68765      68746    IO-APIC-edge  timer
  1:          2          0          2          0    IO-APIC-edge  keyboard
  2:          0          0          0          0          XT-PIC  cascade
  8:          0          0          0          1    IO-APIC-edge  rtc
 10:       4698       4589       4665       4669   IO-APIC-level  ida0, ida1
 12:          2          4          1          0    IO-APIC-edge  PS/2 Mouse
 13:          1          0          0          0          XT-PIC  fpu
 14:          6          0          2          3    IO-APIC-edge  ide0
 15:      25522      22140      22049      21932   IO-APIC-level  eth3
NMI:          0
ERR:          0

io-ports:

0000-001f : dma1
0020-003f : pic1
0040-005f : timer
0060-006f : keyboard
0070-007f : rtc
0080-008f : dma page reg
00a0-00bf : pic2
00c0-00df : dma2
00f0-00ff : fpu
01f0-01f7 : ide0
02f8-02ff : serial(auto)
03c0-03df : vga+
03f6-03f6 : ide0
03f8-03ff : serial(auto)
2c00-2c07 : ide0
3000-301f : Intel Speedo3 Ethernet
3020-303f : Intel Speedo3 Ethernet
4000-401f : Intel Speedo3 Ethernet
4020-403f : Intel Speedo3 Ethernet
ioports (END)

meminfo:
        total:    used:    free:  shared: buffers:  cached:
Mem:  3818278912 131698688 3686580224 73920512 54337536 24928256
Swap: 2147467264        0 2147467264
MemTotal:   3728788 kB
MemFree:    3600176 kB
MemShared:    72188 kB
Buffers:      53064 kB
Cached:       24344 kB
BigTotal:   1802236 kB
BigFree:    1785020 kB
SwapTotal:  2097136 kB
SwapFree:   2097136 kB

partitions:
major minor  #blocks  name     rio rmerge rsect ruse wio wmerge wsect wuse running use aveq

  73     0   26670960 ida/c1d0 0 7 25884 0 0 57 4400 0 3726 3283210 -2082039758
  73     1   10240784 ida/c1d0p1 0 0 0 0 0 0 0 0 0 0 0
  73     2   10240800 ida/c1d0p2 0 7 25874 0 0 574400 0 3724 3279500 -2088603648
  73     3    2101200 ida/c1d0p3 0 0 8 0 0 0 0 0 1 3280680 3280680
  73    16   26675040 ida/c1d1 0 0 2 0 0 0 0 0 1 3283200 3283200
  73    17   26674160 ida/c1d1p1 0 0 0 0 0 0 0 0 0 0 0
  72     0    8882160 ida/c0d0 0 7481 147688 0 0 855 38118 0 15110 3283190 2026511386
  72     1      36704 ida/c0d0p1 0 0 0 0 0 0 0 0 0 0 0
  72     2      16320 ida/c0d0p2 0 263 556 0 0 2 22 0 24 3279500 77197480
  72     3    4124880 ida/c0d0p3 0 0 0 0 0 0 0 0 0 0 0
  72     4          1 ida/c0d0p4 0 0 2 0 0 0 0 0 1 3283180 3283180
  72     5     131072 ida/c0d0p5 0 0 0 0 0 0 0 0 0 0 0
  72     6    2097152 ida/c0d0p6 0 7214 146796 0 0 853 38080 0 15040 3283170 1800133266
  72     7    2097152 ida/c0d0p7 0 4 332 0 0 0 16 0 44 3283160 142614270

PCI:
PCI devices found:
  Bus  0, device   1, function  0:
    PCI bridge: DEC DC21154 (rev 2).
      Medium devsel.  Fast back-to-back capable.  Master Capable.  Latency=64.  Min Gnt=7
.
  Bus  4, device   2, function  0:
    PCI bridge: DEC DC21154 (rev 2).
      Medium devsel.  Fast back-to-back capable.  Master Capable.  Latency=64.  Min Gnt=7
.
  Bus  0, device  11, function  0:
    Unknown class: Compaq Unknown device (rev 4).
      Vendor id=e11. Device id=a0f7.
      Medium devsel.  IRQ 5.
      Non-prefetchable 32 bit memory at 0xe7cf0000 [0xe7cf0000].
  Bus  4, device  11, function  0:
    Unknown class: Compaq Unknown device (rev 4).
      Vendor id=e11. Device id=a0f7.
      Medium devsel.  IRQ 5.
      Non-prefetchable 32 bit memory at 0xf7bf0000 [0xf7bf0000].
  Bus  0, device  12, function  0:
    System peripheral: Compaq Unknown device (rev 0).
      Vendor id=e11. Device id=a0f0.
      Medium devsel.
      I/O at 0x1800 [0x1801].
      Non-prefetchable 32 bit memory at 0xe7ce0000 [0xe7ce0000].
  Bus  0, device  13, function  0:
    SCSI storage controller: NCR 53c875 (rev 20).
      Medium devsel.  IRQ 10.  Master Capable.  Latency=255.  Min Gnt=17.Max Lat=64.
      I/O at 0x2000 [0x2001].
      Non-prefetchable 32 bit memory at 0xe7cd0000 [0xe7cd0000].
      Non-prefetchable 32 bit memory at 0xe7cc0000 [0xe7cc0000].
  Bus  0, device  13, function  1:
    SCSI storage controller: NCR 53c875 (rev 20).
      Medium devsel.  IRQ 11.  Master Capable.  Latency=255.  Min Gnt=17.Max Lat=64.
      I/O at 0x2400 [0x2401].
      Non-prefetchable 32 bit memory at 0xe7cb0000 [0xe7cb0000].
      Non-prefetchable 32 bit memory at 0xe7ca0000 [0xe7ca0000].
  Bus  0, device  14, function  0:
    VGA compatible controller: ATI Unknown device (rev 122).
      Vendor id=1002. Device id=4756.
      Medium devsel.  Fast back-to-back capable.  Master Capable.  Latency=64.  Min Gnt=8
.
      Prefetchable 32 bit memory at 0xe6000000 [0xe6000008].
      I/O at 0x2800 [0x2801].
      Non-prefetchable 32 bit memory at 0xe7c90000 [0xe7c90000].
  Bus  0, device  15, function  0:
    ISA bridge: Intel 82371AB PIIX4 ISA (rev 2).
      Medium devsel.  Fast back-to-back capable.  Master Capable.  No bursts.
  Bus  0, device  15, function  1:
    IDE interface: Intel 82371AB PIIX4 IDE (rev 1).
      Medium devsel.  Fast back-to-back capable.  Master Capable.  Latency=64.
      I/O at 0x2c00 [0x2c01].
  Bus  0, device  15, function  2:
    USB Controller: Intel 82371AB PIIX4 USB (rev 1).
      Medium devsel.  Fast back-to-back capable.  Master Capable.  Latency=64.
      I/O at 0x2c20 [0x2c21].
  Bus  0, device  15, function  3:
    Bridge: Intel 82371AB PIIX4 ACPI (rev 2).
      Medium devsel.  Fast back-to-back capable.
Bus  0, device  16, function  0:
    Host bridge: Intel 450NX - 82451NX Memory & I/O Controller (rev 3).
      Fast devsel.
  Bus  0, device  18, function  0:
    Host bridge: Intel 450NX - 82454NX PCI Expander Bridge (rev 4).
      Medium devsel.  Fast back-to-back capable.  Master Capable.  No bursts.
  Bus  0, device  20, function  0:
    Host bridge: Intel 450NX - 82454NX PCI Expander Bridge (rev 4).
      Medium devsel.  Fast back-to-back capable.  Master Capable.  No bursts.
  Bus  1, device   4, function  0:
    Ethernet controller: Intel 82557 (rev 5).
      Medium devsel.  Fast back-to-back capable.  IRQ 15.  Master Capable.  Latency=64.
Min Gnt=8.Max Lat=56.
      Prefetchable 32 bit memory at 0xe7bf0000 [0xe7bf0008].
      I/O at 0x3000 [0x3001].
      Non-prefetchable 32 bit memory at 0xe7e00000 [0xe7e00000].
  Bus  1, device   5, function  0:
    Ethernet controller: Intel 82557 (rev 5).
      Medium devsel.  Fast back-to-back capable.  IRQ 9.  Master Capable.  Latency=64.  M
in Gnt=8.Max Lat=56.
      Prefetchable 32 bit memory at 0xe7be0000 [0xe7be0008].
      I/O at 0x3020 [0x3021].
      Non-prefetchable 32 bit memory at 0xe7d00000 [0xe7d00000].

cpu: (there are 4 cpus, data is the same for all I only show the first here):
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 7
model name      : Pentium III (Katmai)
stepping        : 2
cpu MHz         : 499.864
cache size      : 1024 KB
fdiv_bug        : no
hlt_bug         : no
sep_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36
 mmx fxsr xmm
bogomips        : 999.42


If you need additional information feel free to contact me. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start install process
2.
3.
	

Additional info:
Comment 1 Brent Fox 2001-10-04 10:41:19 EDT
Try booting with 'linux nousb'.  Does that get around the problem?  If not, the
the problem isn't USB related.
Comment 2 Michael Timony 2001-10-08 10:44:45 EDT
Finally got it to work, I passed the following options to the kernel:

linux ide=nodma nousb

ANd the installation/upgrade worked like a dream. The nousb option by itself 
did not solve the problem.

Thanks for the quick response. Would be nice if Redhat mentioned the options 
one can pass to the kernel/installer in their documentation. (If they do so 
already I was unable to find it). Once again thanks.

Note You need to log in before you can comment on or make changes to this bug.