Bug 54281 - segmentation fault of dlh
Summary: segmentation fault of dlh
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: dlh   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: bero
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-02 23:26 UTC by Tzafrir Cohen
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 15:47:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tzafrir Cohen 2001-10-02 23:26:44 UTC
Description of Problem:

segmentation fault on certain inputs

Version-Release number of selected component (if applicable):
0.7d

How Reproducible:

run with the appropriate document.

I am unable to upload  a sample document. However, the fix to that seems to
be:


diff -ur dlh-0.7d/src/dlh.c dlh-new/src/dlh.c
--- dlh-0.7d/src/dlh.c  Wed Oct  3 00:06:17 2001
+++ dlh-new/src/dlh.c   Wed Oct  3 00:06:22 2001
@@ -675,7 +675,7 @@
 static void
 cmd_line_break (struct call * c)
 {
-    if (env && env->e && strcmp(env->e->name, "tabbing") == 0) {
+    if (env && env->e && env->e->name && strcmp(env->e->name, "tabbing")
== 0) {
        fputs("</td></tr>\n", out->file);
        beginning_of_line_offset = ftell(out->file);
        fputs("<tr valign=bottom><td>", out->file);

It is, in fact, quite similar to the existing dlh-0.7d-fix in the source
RPM.



Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Bernhard Rosenkraenzer 2002-02-21 14:36:27 UTC
Since Powertools has been discontinued, there won't be a future release to fix this in.


Note You need to log in before you can comment on or make changes to this bug.