Bug 54283 - Random restarts in both kde and gnome
Random restarts in both kde and gnome
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-02 23:59 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 14:28:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-02 23:59:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)

Description of problem:
Running Redhat 7.1.94 Roswell beta on Soyo Dragon KT266 w/ Promise Fast-
Track100 Lite raid in ide mode. My main problem is that I am getting 
RANDOM restarts while working on my machine. I can't isolate it to a 
single prsogram causing it. It has crashed while:
    Internet Surfing, Codeing in KDE devel, running up2date agent(it 
crashed before update and I ran update to see if an update would fix it, 
it ended up restarting several times during downloads and I kept running 
it till I had everything downloaded and then up2date installed updates/new 
kernel..still random restarts), and it will sometimes do a random restart 
if I simply turn the machine on and leave it at the login. It dosen't 
chose to restart at any set interval of time or with a particular program 
running(at least not a visible program). It has crashed both in KDE and 
gnome.  

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Boot up machine
2.Use machine in normal operations.
3.
	

Actual Results:  Crashes randomly and causes loss of unsaved data. Upon 
reboot I recieve error of file system not cleanly unmounted and boot drops 
to  a root login prompt where I must manualy use "fsck /dev/hdb6" and 
agree to fix many inode offsets and errors.

Expected Results:  Shouldn't restart randomly

Additional info:

The only thing odd I notice during intstall is that it during startup I 
get a message saying that linux couldn't recognize my southbridge, other 
than it was via. 
During install when I told linux to ask for a driver disk I could only 
give it one of the two disks I had.
        1. Promise onboard raid controller drivers 
        2. Driver disk I made from the driver image on cd. 
I chose the driver disk because  with that in expert mode I noticed my via 
rhine onboard ethernet get detected. 
 
 Did I do something wrong on install? What the heck could be doing this 
restart? Hardware or software? I had a similar prob with mandrake 8.1 for 
the hour it was on my machine, I then went for RH beta. I have run my 
system with all drives on via onboard controller and both with and without 
my promise controller enabled in bios and yet it still gives me restarts

New system setup:
SoyoDragon w/ AMD stock 1.4ghz 'Y' week 27 cpu
768MB DDR pc2400 Corsair 
40GB Maxtor : on via onboard pri-slave ATA66
6.5GB Fujitsu :on promise pri-slave ultra DMA 2
16x10x40 yahmaha :on via onboard secondary-master UDMA 1
5x DVD : not currently hooked up
32MB AGP Ati Rage fury 
ATI wonder VE TV card 
onboard cmi audio and via 10/100 
Enermax 450W power supply
Vantec cck6065 HSF with normal sys temps
Comment 1 Ali-Reza Anghaie 2003-04-04 07:50:39 EST
It might also help to know your /etc/sysconfig/harddisks* settings. DMA, etc. 
 
And search the logs for relevent messages. Perhaps dump 'dmesg' to disk via a cron and 
attach the last dmesg before a crash too. 
 
Cheers, -Ali 
Comment 2 Alan Cox 2003-06-05 13:36:03 EDT
Assuming this was the VIA chipset flaw which we now work around. If it happens
with later
errata please re-open

Note You need to log in before you can comment on or make changes to this bug.