This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 54307 - setlocale leaks
setlocale leaks
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-04 01:05 EDT by David Baron
Modified: 2016-11-24 09:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-04 01:06:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
list of tops of stacks at which leaked memory was allocated (13.09 KB, text/plain)
2001-10-04 01:05 EDT, David Baron
no flags Details

  None (edit)
Description David Baron 2001-10-04 01:05:02 EDT
Description of Problem:
  Looking at leak logs (based on overriding |malloc|, |realloc|, |calloc|,
and |free|) of running Mozilla, there are a bunch of leaks noticeable from
the glibc function |setlocale|.

Version-Release number of selected component (if applicable):
  glibc-2.2.2-10

How Reproducible:
  Well, the way I saw it is complicated, but one could presumably also
observe it by writing a tight loop to repeatedly call |setlocale|.

Additional Information:
  I'll attach to the bug a list of the lines at which the chunks of memory
leaked were allocated.  Note that Mozilla calls |setlocale| multiple times.
 Also note that while the line numbers and file names in the list of
tops-of-stacks are correct, the symbol names are incorrect.
Comment 1 David Baron 2001-10-04 01:05:59 EDT
Created attachment 33338 [details]
list of tops of stacks at which leaked memory was allocated
Comment 2 David Baron 2001-10-04 01:16:04 EDT
Actually, I think this bug is NOTABUG, since my for(;;) { setlocale(LC_ALL,
"C"); } didn't leak.  I'm not sure why I'm seeing what I'm seeing, though.

Sorry for the noise.  I should've tried that first.

Note You need to log in before you can comment on or make changes to this bug.