Bug 543111 - gnumeric "left behind" in upgrades to Fedora 12
Summary: gnumeric "left behind" in upgrades to Fedora 12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnumeric
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Huzaifa S. Sidhpurwala
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-01 17:53 UTC by Michal Jaegermann
Modified: 2009-12-03 05:10 UTC (History)
1 user (show)

Fixed In Version: 1.8.4-6.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-03 05:10:58 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2009-12-01 17:53:32 UTC
Description of problem:

Version 1:1.8.4-4.fc12 is the one available for F12.  If it was installed in F10 or F11 then it was currently gnumeric-1.8.4-5.fc10 or gnumeric-1.8.4-5.fc11.  That leaves it as an "orphan" on upgrades to F12 and if installed in F12 then
bug #500890 and bug #505001 presumably still there.

Version-Release number of selected component (if applicable):
gnumeric-1.8.4-4.fc12

Comment 1 Huzaifa S. Sidhpurwala 2009-12-02 05:17:59 UTC
The latest F12 rpm is in testing at:
https://admin.fedoraproject.org/updates/F10/FEDORA-2009-10791

This should resolve your bug.

Comment 2 Michal Jaegermann 2009-12-02 07:27:58 UTC
> The latest F12 rpm is in testing at:
> https://admin.fedoraproject.org/updates/F10/FEDORA-2009-10791

This says _F10_, not F12 and a web page under that URL with a title "gnumeric-1.8.4-5.fc10 bugfix update" agrees.

Also a list                                       
https://admin.fedoraproject.org/updates/search/gnumeric?_csrf_token=fb9a7f22ace1607108965ab99c8ac8048aafcd6b
shows gnumeric update packages for F10 and F11 but none for F12.  Moreover a check on a mirror with updates/testing/12/ notes 312 packages in SRPMS but none of these is gnumeric.

Comment 3 Huzaifa S. Sidhpurwala 2009-12-02 07:32:12 UTC
my bad, it seems F12 is not updated with these patches, will do that now.

Comment 4 Huzaifa S. Sidhpurwala 2009-12-02 07:51:57 UTC
Hi,
Try this please
http://koji.fedoraproject.org/koji/buildinfo?buildID=137573

Comment 5 Michal Jaegermann 2009-12-02 08:37:46 UTC
> Try this please ...
I am fully aware that such version does exist in koji and long enough that one wonders why it was not used in F12 distro.  The problem is that there  are no signed packages in mirrors for Fedora 12 and an upgrade leaves one with
non-working gnumeric as required libraries vanished.

There is quite a few packages in F12 with a similar problem although not for all of these a distro upgrade makes then unfunctional.

Comment 6 Fedora Update System 2009-12-02 09:19:02 UTC
gnumeric-1.8.4-6.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gnumeric-1.8.4-6.fc12

Comment 7 Huzaifa S. Sidhpurwala 2009-12-02 09:20:06 UTC
This should be moved into F12 stable soon, in the meantime can you test and see if it works?

Comment 8 Michal Jaegermann 2009-12-02 17:40:36 UTC
> in the meantime can you test and see if it works?

It does AFAICT after a quick check of 1.8.4-6.fc12 version.  Although writing out a file as a "LaTeX table fragment" was very slow.  It is true that a resulting LaTeX code was around 13 MB in size and a spreadsheet was created by loading some data in a CSV format and ended up with over 28000 rows but I was already pretty convinced the the whole thing crashed while writing.  I was patient enough to find out that it did not.

Comment 9 Fedora Update System 2009-12-03 05:10:52 UTC
gnumeric-1.8.4-6.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.