This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 54331 - Install uses the /proc/array file for detection
Install uses the /proc/array file for detection
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-04 09:10 EDT by Bryan Leopard
Modified: 2007-04-18 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-17 15:05:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bryan Leopard 2001-10-04 09:10:36 EDT
In later versions of the driver we have changed the name of this file to 
cpqarray.  If we do this, RH6.2 and RH7.0 will no longer detect that our 
driver has disks available.
Comment 1 Brent Fox 2001-10-04 10:36:13 EDT
I'm trying to understand...you've changed the cpqarray driver to use
/proc/cpqarray instead of /proc/array, right?
Comment 2 Brent Fox 2001-10-04 14:10:51 EDT
Does 7.1 work?
Comment 3 Brent Fox 2001-10-15 12:24:18 EDT
Any more info here?
Comment 4 charles.white 2001-10-15 13:35:34 EDT
Yes, RH 7.1 has the same issue... 
We changed to name of the /proc file in version 2.4.5.  
to get it to see the harddrives I had to change the /proc file back to the old 
name... Which gets it so it will see the harddrives. 
Comment 5 Brent Fox 2001-10-16 15:29:38 EDT
So what's wrong with the old name?  Can't it just remain /proc/array?  Seems
like that would make things easier for all involved.
Comment 6 charles.white 2001-10-17 09:58:20 EDT
It was a comment from the user, was trying to make the files the driver uses 
more consistant. 
Comment 7 Michael Fulbright 2001-10-17 11:33:40 EDT
Just to see if I understand, the problem is that a driver released by Compaq
(unknown to Red Hat?) after the 6.2 and 7.0 releases has changed its behavior so
that the 6.2 and 7.0 installation programs do not work?
Comment 8 charles.white 2001-10-17 15:05:06 EDT
Yes
Comment 9 Matt Wilson 2001-10-17 16:06:19 EDT
this all works with the latest versions.  The installer correctly works with the
driver we shipped in 7.0.  There isn't a bug in 7.0 with regard to reading "the
wrong file in proc".

Note You need to log in before you can comment on or make changes to this bug.