Bug 54344 - Netscape 4.77 won't call acroread or realplay
Summary: Netscape 4.77 won't call acroread or realplay
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netscape-alpha   
(Show other bugs)
Version: 7.1
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-04 16:07 UTC by Robert M. Riches Jr.
Modified: 2014-03-17 02:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 18:55:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert M. Riches Jr. 2001-10-04 16:07:18 UTC
Description of Problem:  With RH7.0, netscape could call
realplay or acroread to handle appropriate URL types.
With RH7.1 netscape (4.77), the URL is downloaded into
/tmp/MO*.{pdf,ram,...} but the application does not start.
The applications start when called from the command line.
The .mailcap and .mime.types appear to be correct.  I had
originally filed this as a support request, thinking I might
have missed some configuration issue, but support said I
should file it in bugzilla.

Version-Release number of selected component (if applicable):
Netscape 4.77

How Reproducible:
100%

Steps to Reproduce:
1. invoke netscape
2. click on a PDF or RealPlayer link
3. 

Actual Results: The browser says "document: done".  The application
never starts.

Expected Results: The application should be invoked.

Additional Information:

Comment 1 Bill Nottingham 2001-10-04 19:54:07 UTC
Is this using Tru64 Real Audio & acroread?

Comment 2 Robert M. Riches Jr. 2001-10-04 20:30:25 UTC
Both acroread and realplay were installed in /usr/local/bin prior
to installing RH7.1 on the machine.  I believe acroread came from
Compaq's web site (version 4.0, alpha osf1 stout0124 Jan 24 2000
13:01:25).  Realplayer is from the Real Audio web site (version
7.0.3.345, linux-2.0-libc6-alpha-gcc2.95, debian-slink tarball IIRC
because the Redhat tarball would not install).  Both applications
come up and work fine when invoked from a shell prompt.

(When I filed the support request, I had thought perhaps there was
a file somewhere with a list of apps Netscape was allowed to call,
or other configuration item.)


Comment 3 Robert M. Riches Jr. 2001-10-17 18:32:54 UTC
After going a few rounds of attempts with web support, I looked
back in my old notes and found the solution to this problem:
(as root) cd /usr/bin ; ln -s /bin/sh

Apparently, Netscape (from Digital Unix alias OSF alias Tru64)
expects to find "sh" in /usr/bin, while Redhat Linux puts it in
/bin only.

Perhaps the RPM should include the symlink.

After someone gets around to looking at this report and deciding
whether to consider putting the symlink into the RPM, I consider
this report to be closed.


Comment 4 Rik van Riel 2004-10-15 18:55:16 UTC
Both Netscape and Alpha seem to have disappeared ...


Note You need to log in before you can comment on or make changes to this bug.